summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-23 12:53:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-23 20:54:04 +0100
commit50ed030f17aa49d6b88e821ff6d373d309617211 (patch)
tree485d2ed0d2023c8d11cec1c706c352682ff52db3 /meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb
parent70eff092cb455d4e244efbe78852443be4374f8a (diff)
downloadpoky-50ed030f17aa49d6b88e821ff6d373d309617211.tar.gz
ssh-pregen-hostkeys: Add a recipe with pregenerated ssh host keys
Host keys are getting bigger and taking an ever increasing amount of time to generate. Whilst we do need to test that works, we don't need to test it in every image. Add a recipe which can be added to images with pre-generated keys, allowing us to speed up tests on the autobuilder where it makes sense to. (From OE-Core rev: c6c7d16437cbd5ccbee1b99a2154c33fdbac9299) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb')
-rw-r--r--meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb b/meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb
new file mode 100644
index 0000000000..ddd10e6eeb
--- /dev/null
+++ b/meta/recipes-connectivity/ssh-pregen-hostkeys/ssh-pregen-hostkeys_1.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Pre generated host keys mainly for speeding up our qemu tests"
2
3SRC_URI = "file://dropbear_rsa_host_key \
4 file://openssh"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
8
9INHIBIT_DEFAULT_DEPS = "1"
10
11do_install () {
12 install -d ${D}${sysconfdir}/dropbear
13 install ${WORKDIR}/dropbear_rsa_host_key -m 0600 ${D}${sysconfdir}/dropbear/
14
15 install -d ${D}${sysconfdir}/ssh
16 install ${WORKDIR}/openssh/* ${D}${sysconfdir}/ssh/
17 chmod 0600 ${D}${sysconfdir}/ssh/*
18 chmod 0644 ${D}${sysconfdir}/ssh/*.pub
19} \ No newline at end of file