summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.4.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-03 13:32:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-07 14:32:42 +0000
commit1d4fdea68aed94f23bf5d9f3b8a767be46f0ca24 (patch)
tree978fd379fd2e317b2b675458e21c6a2a2759f8dc /meta/recipes-connectivity/socat/socat_1.7.4.4.bb
parent38835266673f969aa50c063c98f84f97a580828c (diff)
downloadpoky-1d4fdea68aed94f23bf5d9f3b8a767be46f0ca24.tar.gz
socat: upgrade 1.7.4.3 -> 1.7.4.4
0001-configure.ac-check-getprotobynumber_r-with-AC_TRY_LI.patch removed since it's included in 1.7.4.4 (From OE-Core rev: c00e9d66f0b8449ff1bf24546f232345eb6feebd) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.4.4.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.4.4.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.4.4.bb b/meta/recipes-connectivity/socat/socat_1.7.4.4.bb
new file mode 100644
index 0000000000..5a379380d1
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.4.4.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8LICENSE = "GPL-2.0-with-OpenSSL-exception"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://README;beginline=257;endline=287;md5=82520b052f322ac2b5b3dfdc7c7eea86"
11
12SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2"
13
14SRC_URI[sha256sum] = "fbd42bd2f0e54a3af6d01bdf15385384ab82dbc0e4f1a5e153b3e0be1b6380ac"
15
16inherit autotools
17
18EXTRA_AUTORECONF += "--exclude=autoheader"
19
20EXTRA_OECONF += "ac_cv_have_z_modifier=yes \
21 ac_cv_header_bsd_libutil_h=no \
22 sc_cv_termios_ispeed=no \
23 ${TERMBITS_SHIFTS} \
24"
25
26TERMBITS_SHIFTS ?= "sc_cv_sys_crdly_shift=9 \
27 sc_cv_sys_tabdly_shift=11 \
28 sc_cv_sys_csize_shift=4"
29
30TERMBITS_SHIFTS:powerpc = "sc_cv_sys_crdly_shift=12 \
31 sc_cv_sys_tabdly_shift=10 \
32 sc_cv_sys_csize_shift=8"
33
34TERMBITS_SHIFTS:powerpc64 = "sc_cv_sys_crdly_shift=12 \
35 sc_cv_sys_tabdly_shift=10 \
36 sc_cv_sys_csize_shift=8"
37
38PACKAGECONFIG:class-target ??= "tcp-wrappers readline openssl"
39PACKAGECONFIG ??= "readline openssl"
40PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
41PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
42PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
43
44CFLAGS += "-fcommon"
45
46do_install:prepend () {
47 mkdir -p ${D}${bindir}
48 install -d ${D}${bindir} ${D}${mandir}/man1
49}
50
51BBCLASSEXTEND = "native nativesdk"