summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.3.0.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-07 04:24:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-08 10:53:27 +0100
commit8bdf8b901247412bada91d72cf6620852d050512 (patch)
tree53cda18575880fb019f7ff0b679b09bff1731740 /meta/recipes-connectivity/socat/socat_1.7.3.0.bb
parent7d6f0709c23bb4e40e6faec923e5f159b87db136 (diff)
downloadpoky-8bdf8b901247412bada91d72cf6620852d050512.tar.gz
socat: 1.7.2.4 -> 1.7.3.0
Removed fix-cross-compiling-failed.patch and socat-1.7.2.4-linux-3.17.patch since upstream has fixed them. Updated README's LIC_FILES_CHKSUM, there is a word changed (GPL -> GPLv2, it should be GPLv2 as COPYING shows), its license is already "GPL-2.0+-with-OpenSSL-exception", so we just update the md5 is OK. (From OE-Core rev: 1c09d06ab8694612e1bd5cc63ad660d1e1ea4d64) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.3.0.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.3.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.3.0.bb b/meta/recipes-connectivity/socat/socat_1.7.3.0.bb
new file mode 100644
index 0000000000..8923f41d8c
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.3.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8DEPENDS = "openssl readline"
9
10LICENSE = "GPL-2.0+-with-OpenSSL-exception"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://README;beginline=257;endline=287;md5=338c05eadd013872abb1d6e198e10a3f"
13
14
15SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
16"
17
18SRC_URI[md5sum] = "b607edb65bc6c57f4a43f06247504274"
19SRC_URI[sha256sum] = "0767e850c0329b9fdf711c6cd468565cbbb28786ba1a8a1cbd5531d4016b3e04"
20
21inherit autotools
22
23EXTRA_AUTORECONF += "--exclude=autoheader"
24
25EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
26 sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
27 ac_cv_ispeed_offset=13 \
28 ac_cv_header_bsd_libutil_h=no \
29"
30
31PACKAGECONFIG ??= "tcp-wrappers"
32PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
33
34do_install_prepend () {
35 mkdir -p ${D}${bindir}
36 install -d ${D}${bindir} ${D}${mandir}/man1
37}