summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-connectivity/socat/socat_1.7.2.4.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.4.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.4.bb b/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
new file mode 100644
index 0000000000..44d72202ac
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.4.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8DEPENDS = "openssl readline"
9
10LICENSE = "GPL-2.0+-with-OpenSSL-exception"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://README;beginline=257;endline=287;md5=79246f11a1db0b6ccec54d1fb711c01e"
13
14
15SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
16 file://fix-cross-compiling-failed.patch \
17"
18
19SRC_URI[md5sum] = "69b8155dd442a6f24e28ef5407d868eb"
20SRC_URI[sha256sum] = "4b7739901c6fad1e460f3e5b1868fb4c2a1427febbba7a510cd2e42fd4941e09"
21
22inherit autotools
23
24EXTRA_AUTORECONF += "--exclude=autoheader"
25
26EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
27 sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
28 ac_cv_ispeed_offset=13 \
29 ac_cv_header_bsd_libutil_h=no \
30"
31
32PACKAGECONFIG ??= "tcp-wrappers"
33PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
34
35do_install_prepend () {
36 mkdir -p ${D}${bindir}
37 install -d ${D}${bindir} ${D}${mandir}/man1
38}