summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.3.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-connectivity/socat/socat_1.7.2.3.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.3.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.3.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.3.bb b/meta/recipes-connectivity/socat/socat_1.7.2.3.bb
new file mode 100644
index 0000000000..99060b15ae
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.3.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8DEPENDS = "openssl readline"
9
10LICENSE = "GPL-2.0+-with-OpenSSL-exception"
11LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
12 file://README;beginline=252;endline=282;md5=79246f11a1db0b6ccec54d1fb711c01e"
13
14
15SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
16 file://compile.patch \
17 file://fix-xxx_SHIFT-autoheader.patch"
18
19SRC_URI[md5sum] = "75008d8baf7c6c9e27aa7afb34a622de"
20SRC_URI[sha256sum] = "0598ac54af7b138cda9e3c141bcf0cc63eeb2ab31f468a772dc3f7eb3896aad0"
21
22PACKAGECONFIG ??= "tcp-wrappers"
23PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
24
25EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
26 sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
27 ac_cv_ispeed_offset=13 \
28"
29
30inherit autotools
31
32do_configure_prepend() {
33 sed '/AC_DEFINE_UNQUOTED(ISPEED_OFFSET/a\AC_DEFINE(OSPEED_OFFSET,\
34(ISPEED_OFFSET+1)\ ,\ [have\ ospeed\ offset])' -i ${S}/configure.in
35}
36
37do_install_prepend () {
38 mkdir -p ${D}${bindir}
39 install -d ${D}${bindir} ${D}${mandir}/man1
40}