summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.0.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-12-19 13:17:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 13:13:45 +0000
commit7bde933974d8ebabd6b0e4bff851f3f3508ddab7 (patch)
treec3dba9288b561bfc1fc656161b4e0771c79ac80c /meta/recipes-connectivity/socat/socat_1.7.2.0.bb
parent13d2dc2c9183c3ef5508fe9806bc06bd1dd19804 (diff)
downloadpoky-7bde933974d8ebabd6b0e4bff851f3f3508ddab7.tar.gz
socat: add the latest stable version 1.7.2.0
socat is useful for the self-hosted-image work. The original recipe is from OE: http://git.openembedded.org/openembedded/tree/recipes/socat/ and I upgraded it to 1.7.2.0. Thank Koen Kooi <koen@dominion.thruhere.net> for suggesting how to assign the LICENSE field with a proper value. (From OE-Core rev: b1771ff0ad39250678bd53b0ae7543c9365572f5) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.0.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.0.bb b/meta/recipes-connectivity/socat/socat_1.7.2.0.bb
new file mode 100644
index 0000000000..1273dcf0f2
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.0.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Socat is a relay for bidirectional data \
2transfer between two independent data channels."
3HOMEPAGE = "http://www.dest-unreach.org/socat/"
4
5SECTION = "console/network"
6
7DEPENDS = "openssl"
8
9LICENSE = "GPL-2.0+-with-OpenSSL-exception"
10
11PR = "r0"
12SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2;name=src \
13 file://compile.patch"
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
16 file://README;beginline=252;endline=282;md5=79246f11a1db0b6ccec54d1fb711c01e"
17
18SRC_URI[src.md5sum] = "eb563dd00b9d39a49fb62a677fc941fe"
19SRC_URI[src.sha256sum] = "59b3bde927c14fbc3f9e42c782971710da8a89bbf46f7531f09a681754041802"
20
21EXTRA_OECONF = " --disable-termios "
22
23inherit autotools
24
25do_install_prepend () {
26 mkdir -p ${D}${bindir}
27 install -d ${D}${bindir} ${D}${mandir}/man1
28}