diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2016-06-12 10:21:07 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-06-15 08:35:00 +0100 |
commit | 4b777079066e6fa72d7c9db1e1cae3ebb9338351 (patch) | |
tree | d19749a1f6bfb2916f20f0940f831c7b1b5e7ca8 /meta/recipes-connectivity/resolvconf/resolvconf_1.79.bb | |
parent | ff1105f2dc34035b0c7502605e54accadf1ee2ab (diff) | |
download | poky-4b777079066e6fa72d7c9db1e1cae3ebb9338351.tar.gz |
resolvconf: upgrade to 1.79
(From OE-Core rev: 439bee0777fb570858979acfbe20e9829f86412b)
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.79.bb')
-rw-r--r-- | meta/recipes-connectivity/resolvconf/resolvconf_1.79.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.79.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.79.bb new file mode 100644 index 0000000000..8550177288 --- /dev/null +++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.79.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "name server information handler" | ||
2 | DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \ | ||
3 | information about currently available nameservers. It sets \ | ||
4 | itself up as the intermediary between programs that supply \ | ||
5 | nameserver information and programs that need nameserver \ | ||
6 | information." | ||
7 | SECTION = "console/network" | ||
8 | LICENSE = "GPLv2+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b" | ||
10 | AUTHOR = "Thomas Hood" | ||
11 | HOMEPAGE = "http://packages.debian.org/resolvconf" | ||
12 | RDEPENDS_${PN} = "bash" | ||
13 | |||
14 | SRC_URI = "http://snapshot.debian.org/archive/debian/20160520T044340Z/pool/main/r/${BPN}/${BPN}_1.79.tar.xz \ | ||
15 | file://fix-path-for-busybox.patch \ | ||
16 | file://99_resolvconf \ | ||
17 | " | ||
18 | |||
19 | SRC_URI[md5sum] = "aab2382020fc518f06a06e924c56d300" | ||
20 | SRC_URI[sha256sum] = "8e2843cd4162b706f0481b3c281657728cbc2822e50a64fff79b79bd8aa870a0" | ||
21 | |||
22 | # the package is taken from snapshots.debian.org; that source is static and goes stale | ||
23 | # so we check the latest upstream from a directory that does get updated | ||
24 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/" | ||
25 | |||
26 | inherit allarch | ||
27 | |||
28 | do_compile () { | ||
29 | : | ||
30 | } | ||
31 | |||
32 | do_install () { | ||
33 | install -d ${D}${sysconfdir}/default/volatiles | ||
34 | install -m 0644 ${WORKDIR}/99_resolvconf ${D}${sysconfdir}/default/volatiles | ||
35 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
36 | install -d ${D}${sysconfdir}/tmpfiles.d | ||
37 | echo "d /run/${BPN}/interface - - - -" \ | ||
38 | > ${D}${sysconfdir}/tmpfiles.d/resolvconf.conf | ||
39 | fi | ||
40 | install -d ${D}${base_libdir}/${BPN} | ||
41 | install -d ${D}${sysconfdir}/${BPN} | ||
42 | ln -snf ${localstatedir}/run/${BPN} ${D}${sysconfdir}/${BPN}/run | ||
43 | install -d ${D}${sysconfdir} ${D}${base_sbindir} | ||
44 | install -d ${D}${mandir}/man8 ${D}${docdir}/${P} | ||
45 | cp -pPR etc/* ${D}${sysconfdir}/ | ||
46 | chown -R root:root ${D}${sysconfdir}/ | ||
47 | install -m 0755 bin/resolvconf ${D}${base_sbindir}/ | ||
48 | install -m 0755 bin/list-records ${D}${base_libdir}/${BPN} | ||
49 | install -d ${D}/${sysconfdir}/network/if-up.d | ||
50 | install -m 0755 debian/resolvconf.000resolvconf.if-up ${D}/${sysconfdir}/network/if-up.d/000resolvconf | ||
51 | install -d ${D}/${sysconfdir}/network/if-down.d | ||
52 | install -m 0755 debian/resolvconf.resolvconf.if-down ${D}/${sysconfdir}/network/if-down.d/resolvconf | ||
53 | install -m 0644 README ${D}${docdir}/${P}/ | ||
54 | install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/ | ||
55 | } | ||
56 | |||
57 | pkg_postinst_${PN} () { | ||
58 | if [ -z "$D" ]; then | ||
59 | if command -v systemd-tmpfiles >/dev/null; then | ||
60 | systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/resolvconf.conf | ||
61 | elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then | ||
62 | ${sysconfdir}/init.d/populate-volatile.sh update | ||
63 | fi | ||
64 | fi | ||
65 | } | ||
66 | |||
67 | FILES_${PN} += "${base_libdir}/${BPN}" | ||