summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-06 15:57:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-09 23:47:55 +0100
commit7aa8658d0504bcd9554dfa5fedffa7b4936d87ca (patch)
treea5f3c1c91e6b4d8e413949f6c4bc2ab820bf7fa3 /meta/recipes-connectivity/ppp/ppp_2.4.7.bb
parentdbda297fd91aab2727f7a69d3b7d3a32ad4261d2 (diff)
downloadpoky-7aa8658d0504bcd9554dfa5fedffa7b4936d87ca.tar.gz
ppp: Use openssl for the DES instead of the libcrypt / glibc
(From OE-Core rev: bdf443c8fce628a93f1ad5100dcaeb3c0f3a70ad) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/ppp/ppp_2.4.7.bb')
-rw-r--r--meta/recipes-connectivity/ppp/ppp_2.4.7.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/ppp/ppp_2.4.7.bb b/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
index a1bb7d71c1..f4646bd693 100644
--- a/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
+++ b/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
@@ -4,7 +4,7 @@ the Point-to-Point Protocol (PPP) on Linux and Solaris systems."
4SECTION = "console/network" 4SECTION = "console/network"
5HOMEPAGE = "http://samba.org/ppp/" 5HOMEPAGE = "http://samba.org/ppp/"
6BUGTRACKER = "http://ppp.samba.org/cgi-bin/ppp-bugs" 6BUGTRACKER = "http://ppp.samba.org/cgi-bin/ppp-bugs"
7DEPENDS = "libpcap" 7DEPENDS = "libpcap openssl"
8LICENSE = "BSD & GPLv2+ & LGPLv2+ & PD" 8LICENSE = "BSD & GPLv2+ & LGPLv2+ & PD"
9LIC_FILES_CHKSUM = "file://pppd/ccp.c;beginline=1;endline=29;md5=e2c43fe6e81ff77d87dc9c290a424dea \ 9LIC_FILES_CHKSUM = "file://pppd/ccp.c;beginline=1;endline=29;md5=e2c43fe6e81ff77d87dc9c290a424dea \
10 file://pppd/plugins/passprompt.c;beginline=1;endline=10;md5=3bcbcdbf0e369c9a3e0b8c8275b065d8 \ 10 file://pppd/plugins/passprompt.c;beginline=1;endline=10;md5=3bcbcdbf0e369c9a3e0b8c8275b065d8 \
@@ -32,6 +32,7 @@ SRC_URI = "https://download.samba.org/pub/${BPN}/${BP}.tar.gz \
32 file://fix-CVE-2015-3310.patch \ 32 file://fix-CVE-2015-3310.patch \
33 file://0001-pppoe-include-netinet-in.h-before-linux-in.h.patch \ 33 file://0001-pppoe-include-netinet-in.h-before-linux-in.h.patch \
34 file://0001-ppp-Remove-unneeded-include.patch \ 34 file://0001-ppp-Remove-unneeded-include.patch \
35 file://ppp-2.4.7-DES-openssl.patch \
35" 36"
36 37
37SRC_URI_append_libc-musl = "\ 38SRC_URI_append_libc-musl = "\
@@ -49,7 +50,7 @@ EXTRA_OECONF = "--disable-strip"
49# Package Makefile computes CFLAGS, referencing COPTS. 50# Package Makefile computes CFLAGS, referencing COPTS.
50# Typically hard-coded to '-O2 -g' in the Makefile's. 51# Typically hard-coded to '-O2 -g' in the Makefile's.
51# 52#
52EXTRA_OEMAKE += ' COPTS="${CFLAGS} -I${S}/include"' 53EXTRA_OEMAKE += ' COPTS="${CFLAGS} -I${STAGING_INCDIR}/openssl -I${S}/include"'
53 54
54do_configure () { 55do_configure () {
55 oe_runconf 56 oe_runconf