diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:11 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:57 +0100 |
commit | d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch) | |
tree | f36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-connectivity/ppp/ppp_2.4.5.bb | |
parent | caab7fc509bf27706ff3248689f6afd04225cfda (diff) | |
download | poky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz |
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity/ppp/ppp_2.4.5.bb')
-rw-r--r-- | meta/recipes-connectivity/ppp/ppp_2.4.5.bb | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ppp/ppp_2.4.5.bb b/meta/recipes-connectivity/ppp/ppp_2.4.5.bb new file mode 100644 index 0000000000..e9caf3d13e --- /dev/null +++ b/meta/recipes-connectivity/ppp/ppp_2.4.5.bb | |||
@@ -0,0 +1,77 @@ | |||
1 | DESCRIPTION = "ppp (Paul's PPP Package) is an open source package which implements \ | ||
2 | the Point-to-Point Protocol (PPP) on Linux and Solaris systems." | ||
3 | SECTION = "console/network" | ||
4 | HOMEPAGE = "http://samba.org/ppp/" | ||
5 | BUGTRACKER = "http://ppp.samba.org/cgi-bin/ppp-bugs" | ||
6 | DEPENDS = "libpcap" | ||
7 | LICENSE = "BSD & GPLv2+ & LGPLv2+ & public domain" | ||
8 | LIC_FILES_CHKSUM = "file://pppd/ccp.c;beginline=1;endline=29;md5=e2c43fe6e81ff77d87dc9c290a424dea \ | ||
9 | file://pppd/plugins/passprompt.c;beginline=1;endline=10;md5=3bcbcdbf0e369c9a3e0b8c8275b065d8 \ | ||
10 | file://pppd/tdb.c;beginline=1;endline=27;md5=4ca3a9991b011038d085d6675ae7c4e6 \ | ||
11 | file://chat/chat.c;beginline=1;endline=15;md5=0d374b8545ee5c62d7aff1acbd38add2" | ||
12 | PR = "r0" | ||
13 | |||
14 | SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \ | ||
15 | file://makefile.patch \ | ||
16 | file://cifdefroute.patch \ | ||
17 | file://pppd-resolv-varrun.patch \ | ||
18 | file://enable-ipv6.patch \ | ||
19 | file://makefile-remove-hard-usr-reference.patch \ | ||
20 | file://pon \ | ||
21 | file://poff \ | ||
22 | file://init \ | ||
23 | file://ip-up \ | ||
24 | file://ip-down \ | ||
25 | file://08setupdns \ | ||
26 | file://92removedns" | ||
27 | |||
28 | SRC_URI_append_nylon = " file://ppp-tdbread.patch;patch=1" | ||
29 | |||
30 | inherit autotools | ||
31 | |||
32 | EXTRA_OEMAKE = "STRIPPROG=${STRIP} MANDIR=${D}${datadir}/man/man8 INCDIR=${D}/usr/include LIBDIR=${D}/usr/lib/pppd/${PV} BINDIR=${D}/usr/sbin" | ||
33 | EXTRA_OECONF = "--disable-strip" | ||
34 | |||
35 | do_install_append () { | ||
36 | make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp | ||
37 | mkdir -p ${D}${bindir}/ ${D}${sysconfdir}/init.d | ||
38 | mkdir -p ${D}${sysconfdir}/ppp/ip-up.d/ | ||
39 | mkdir -p ${D}${sysconfdir}/ppp/ip-down.d/ | ||
40 | install -m 0755 ${WORKDIR}/pon ${D}${bindir}/pon | ||
41 | install -m 0755 ${WORKDIR}/poff ${D}${bindir}/poff | ||
42 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ppp | ||
43 | install -m 0755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/ | ||
44 | install -m 0755 ${WORKDIR}/ip-down ${D}${sysconfdir}/ppp/ | ||
45 | install -m 0755 ${WORKDIR}/08setupdns ${D}${sysconfdir}/ppp/ip-up.d/ | ||
46 | install -m 0755 ${WORKDIR}/92removedns ${D}${sysconfdir}/ppp/ip-down.d/ | ||
47 | rm -rf ${D}/${mandir}/man8/man8 | ||
48 | } | ||
49 | |||
50 | CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options" | ||
51 | PACKAGES += "ppp-oa ppp-oe ppp-radius ppp-winbind ppp-minconn ppp-password ppp-tools" | ||
52 | FILES_${PN} = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd" | ||
53 | FILES_${PN}_nylon = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd /usr/sbin/tdbread" | ||
54 | FILES_${PN}-dbg += "${libdir}/pppd/2.4.3/.debug" | ||
55 | FILES_ppp-oa = "/usr/lib/pppd/2.4.3/pppoatm.so" | ||
56 | FILES_ppp-oe = "/usr/sbin/pppoe-discovery /usr/lib/pppd/2.4.3/rp-pppoe.so" | ||
57 | FILES_ppp-radius = "/usr/lib/pppd/2.4.3/radius.so /usr/lib/pppd/2.4.3/radattr.so /usr/lib/pppd/2.4.3/radrealms.so" | ||
58 | FILES_ppp-winbind = "/usr/lib/pppd/2.4.3/winbind.so" | ||
59 | FILES_ppp-minconn = "/usr/lib/pppd/2.4.3/minconn.so" | ||
60 | FILES_ppp-password = "/usr/lib/pppd/2.4.3/pass*.so" | ||
61 | FILES_ppp-tools = "/usr/sbin/pppstats /usr/sbin/pppdump" | ||
62 | DESCRIPTION_ppp-oa = "Plugin for PPP needed for PPP-over-ATM" | ||
63 | DESCRIPTION_ppp-oe = "Plugin for PPP needed for PPP-over-Ethernet" | ||
64 | DESCRIPTION_ppp-radius = "Plugin for PPP that are related to RADIUS" | ||
65 | DESCRIPTION_ppp-winbind = "Plugin for PPP to authenticate against Samba or Windows" | ||
66 | DESCRIPTION_ppp-minconn = "Plugin for PPP to specify a minimum connect time before the idle timeout applies" | ||
67 | DESCRIPTION_ppp-password = "Plugin for PPP to get passwords via a pipe" | ||
68 | DESCRIPTION_ppp-tools = "The pppdump and pppstats utitilities" | ||
69 | RDEPENDS_ppp_minconn += "libpcap0.8" | ||
70 | |||
71 | pkg_postinst_${PN}() { | ||
72 | if test "x$D" != "x"; then | ||
73 | exit 1 | ||
74 | else | ||
75 | chmod u+s ${sbindir}/pppd | ||
76 | fi | ||
77 | } | ||