summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:38:32 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:50:20 +0100
commite2e6f6fe07049f33cb6348780fa975162752e421 (patch)
treeb1813295411235d1297a0ed642b1346b24fdfb12 /meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
downloadpoky-e2e6f6fe07049f33cb6348780fa975162752e421.tar.gz
initial commit of Enea Linux 3.1
Migrated from the internal git server on the dora-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb')
-rw-r--r--meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
new file mode 100644
index 0000000000..d239c20b21
--- /dev/null
+++ b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
@@ -0,0 +1,26 @@
1SECTION = "console/network"
2DESCRIPTION = "Enables PPP dial-in through a serial connection"
3DEPENDS = "ppp"
4RDEPENDS_${PN} = "ppp"
5PR = "r8"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10SRC_URI = "file://host-peer \
11 file://ppp-dialin"
12
13inherit allarch useradd
14
15do_install() {
16 install -d ${D}${sysconfdir}/ppp/peers
17 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
18
19 install -d ${D}${sbindir}
20 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
21}
22
23USERADD_PACKAGES = "${PN}"
24USERADD_PARAM_${PN} = "--system --home /dev/null \
25 --no-create-home --shell ${sbindir}/ppp-dialin \
26 --no-user-group --gid nogroup ppp"