summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/portmap/portmap_6.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-connectivity/portmap/portmap_6.0.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-connectivity/portmap/portmap_6.0.bb')
-rw-r--r--meta/recipes-connectivity/portmap/portmap_6.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/portmap/portmap_6.0.bb b/meta/recipes-connectivity/portmap/portmap_6.0.bb
new file mode 100644
index 0000000000..8b65a03346
--- /dev/null
+++ b/meta/recipes-connectivity/portmap/portmap_6.0.bb
@@ -0,0 +1,31 @@
1require portmap.inc
2
3PR = "r9"
4
5SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
6 file://destdir-no-strip.patch \
7 file://tcpd-config.patch \
8 file://portmap.init \
9 file://portmap.service"
10
11SRC_URI[md5sum] = "ac108ab68bf0f34477f8317791aaf1ff"
12SRC_URI[sha256sum] = "02c820d39f3e6e729d1bea3287a2d8a6c684f1006fb9612f97dcad4a281d41de"
13
14S = "${WORKDIR}/${BPN}_${PV}/"
15
16PACKAGECONFIG ??= "tcp-wrappers"
17PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers"
18
19CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS -DHOSTS_ACCESS"
20CFLAGS += "-Wall -Wstrict-prototypes -fPIC"
21EXTRA_OEMAKE += "'NO_TCP_WRAPPER=${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', '', '1', d)}'"
22
23fakeroot do_install() {
24 install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d
25 install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
26 oe_runmake install DESTDIR=${D}
27
28 install -d ${D}${systemd_unitdir}/system
29 install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
30 sed -i -e 's,@BASE_SBINDIR@,${base_sbindir},g' ${D}${systemd_unitdir}/system/portmap.service
31}