summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/portmap/portmap_6.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-connectivity/portmap/portmap_6.0.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-connectivity/portmap/portmap_6.0.bb')
-rw-r--r--meta/recipes-connectivity/portmap/portmap_6.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/portmap/portmap_6.0.bb b/meta/recipes-connectivity/portmap/portmap_6.0.bb
new file mode 100644
index 0000000000..68dd79625d
--- /dev/null
+++ b/meta/recipes-connectivity/portmap/portmap_6.0.bb
@@ -0,0 +1,26 @@
1require portmap.inc
2
3PR = "r9"
4
5SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
6 file://destdir-no-strip.patch \
7 file://tcpd-config.patch \
8 file://portmap.init"
9
10SRC_URI[md5sum] = "ac108ab68bf0f34477f8317791aaf1ff"
11SRC_URI[sha256sum] = "02c820d39f3e6e729d1bea3287a2d8a6c684f1006fb9612f97dcad4a281d41de"
12
13S = "${WORKDIR}/${BPN}_${PV}/"
14
15PACKAGECONFIG ??= "tcp-wrappers"
16PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers"
17
18CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS -DHOSTS_ACCESS"
19CFLAGS += "-Wall -Wstrict-prototypes -fPIC"
20EXTRA_OEMAKE += "'NO_TCP_WRAPPER=${@base_contains('PACKAGECONFIG', 'tcp-wrappers', '', '1', d)}'"
21
22fakeroot do_install() {
23 install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d
24 install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
25 oe_runmake install DESTDIR=${D}
26}