diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2018-08-16 21:43:33 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-20 17:38:23 +0100 |
commit | 7e850872d39fae341b0107ab634cb85bc14c4ffa (patch) | |
tree | e9badd0aa53f63f3fc93a5ec9c1f209fd8f1f3f6 /meta/recipes-connectivity/openssl/openssl_1.1.0i.bb | |
parent | c64eec1e67b474b446579a1e0f174b584aa48e2f (diff) | |
download | poky-7e850872d39fae341b0107ab634cb85bc14c4ffa.tar.gz |
openssl: minor reformatting to align the 1.0 and 1.1 recipes
Formatting and comment tweaks only, no functional changes.
(From OE-Core rev: 06da559b5becee1b5fcc2263f6edd95f6d305fc2)
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.1.0i.bb')
-rw-r--r-- | meta/recipes-connectivity/openssl/openssl_1.1.0i.bb | 36 |
1 files changed, 20 insertions, 16 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb index ab0d2648f9..3d4b7eee4e 100644 --- a/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb +++ b/meta/recipes-connectivity/openssl/openssl_1.1.0i.bb | |||
@@ -106,16 +106,16 @@ do_configure () { | |||
106 | 106 | ||
107 | do_install () { | 107 | do_install () { |
108 | oe_runmake DESTDIR="${D}" MANDIR="${mandir}" MANSUFFIX=ssl install | 108 | oe_runmake DESTDIR="${D}" MANDIR="${mandir}" MANSUFFIX=ssl install |
109 | |||
109 | oe_multilib_header openssl/opensslconf.h | 110 | oe_multilib_header openssl/opensslconf.h |
110 | 111 | ||
111 | # Create SSL structure for PATH hard-coded packages like ca-certificates | 112 | # Create SSL structure for packages such as ca-certificates which |
112 | # Debian is also using this technique | 113 | # contain hard-coded paths to /etc/ssl. Debian does the same. |
113 | install -d ${D}${sysconfdir}/ssl/ | 114 | install -d ${D}${sysconfdir}/ssl |
114 | mv ${D}${libdir}/ssl-1.1/openssl.cnf \ | 115 | mv ${D}${libdir}/ssl-1.1/certs \ |
115 | ${D}${libdir}/ssl-1.1/certs \ | 116 | ${D}${libdir}/ssl-1.1/private \ |
116 | ${D}${libdir}/ssl-1.1/private \ | 117 | ${D}${libdir}/ssl-1.1/openssl.cnf \ |
117 | \ | 118 | ${D}${sysconfdir}/ssl/ |
118 | ${D}${sysconfdir}/ssl/ | ||
119 | ln -sf ${sysconfdir}/ssl/certs ${D}${libdir}/ssl-1.1/certs | 119 | ln -sf ${sysconfdir}/ssl/certs ${D}${libdir}/ssl-1.1/certs |
120 | ln -sf ${sysconfdir}/ssl/private ${D}${libdir}/ssl-1.1/private | 120 | ln -sf ${sysconfdir}/ssl/private ${D}${libdir}/ssl-1.1/private |
121 | ln -sf ${sysconfdir}/ssl/openssl.cnf ${D}${libdir}/ssl-1.1/openssl.cnf | 121 | ln -sf ${sysconfdir}/ssl/openssl.cnf ${D}${libdir}/ssl-1.1/openssl.cnf |
@@ -134,7 +134,7 @@ do_install_append_class-nativesdk () { | |||
134 | install -m 644 ${WORKDIR}/environment.d-openssl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh | 134 | install -m 644 ${WORKDIR}/environment.d-openssl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh |
135 | } | 135 | } |
136 | 136 | ||
137 | do_install_ptest() { | 137 | do_install_ptest () { |
138 | cp -r * ${D}${PTEST_PATH} | 138 | cp -r * ${D}${PTEST_PATH} |
139 | 139 | ||
140 | # Putting .so files in ptest package will mess up the dependencies of the main openssl package | 140 | # Putting .so files in ptest package will mess up the dependencies of the main openssl package |
@@ -144,22 +144,26 @@ do_install_ptest() { | |||
144 | sed -i 's/$target{shared_extension_simple}/".so.ptest"/' ${D}${PTEST_PATH}/test/recipes/90-test_shlibload.t | 144 | sed -i 's/$target{shared_extension_simple}/".so.ptest"/' ${D}${PTEST_PATH}/test/recipes/90-test_shlibload.t |
145 | } | 145 | } |
146 | 146 | ||
147 | PACKAGES =+ "libcrypto libssl ${PN}-misc ${PN}-engines openssl-conf" | 147 | # Add the openssl.cnf file to the openssl-conf package. Make the libcrypto |
148 | # package RRECOMMENDS on this package. This will enable the configuration | ||
149 | # file to be installed for both the openssl-bin package and the libcrypto | ||
150 | # package since the openssl-bin package depends on the libcrypto package. | ||
151 | |||
152 | PACKAGES =+ "libcrypto libssl openssl-conf ${PN}-engines ${PN}-misc" | ||
148 | 153 | ||
149 | FILES_libcrypto = "${libdir}/libcrypto${SOLIBS}" | 154 | FILES_libcrypto = "${libdir}/libcrypto${SOLIBS}" |
150 | FILES_libssl = "${libdir}/libssl${SOLIBS}" | 155 | FILES_libssl = "${libdir}/libssl${SOLIBS}" |
151 | FILES_${PN} =+ "${libdir}/ssl-1.1/*" | 156 | FILES_openssl-conf = "${sysconfdir}/ssl/openssl.cnf ${libdir}/ssl-1.1/openssl.cnf" |
152 | FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/openssl.sh" | ||
153 | FILES_${PN}-engines = "${libdir}/engines-1.1" | 157 | FILES_${PN}-engines = "${libdir}/engines-1.1" |
154 | |||
155 | FILES_${PN}-misc = "${libdir}/ssl-1.1/misc" | 158 | FILES_${PN}-misc = "${libdir}/ssl-1.1/misc" |
156 | RDEPENDS_${PN}-misc = "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}" | 159 | FILES_${PN} =+ "${libdir}/ssl-1.1/*" |
160 | FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/openssl.sh" | ||
157 | 161 | ||
158 | FILES_openssl-conf = "${sysconfdir}/ssl/openssl.cnf ${libdir}/ssl-1.1/openssl.cnf" | ||
159 | CONFFILES_openssl-conf = "${sysconfdir}/ssl/openssl.cnf" | 162 | CONFFILES_openssl-conf = "${sysconfdir}/ssl/openssl.cnf" |
160 | RRECOMMENDS_libcrypto += "openssl-conf" | ||
161 | 163 | ||
164 | RRECOMMENDS_libcrypto += "openssl-conf" | ||
162 | RDEPENDS_${PN}-bin = "perl" | 165 | RDEPENDS_${PN}-bin = "perl" |
166 | RDEPENDS_${PN}-misc = "${@bb.utils.filter('PACKAGECONFIG', 'perl', d)}" | ||
163 | RDEPENDS_${PN}-ptest += "perl-module-file-spec-functions bash python" | 167 | RDEPENDS_${PN}-ptest += "perl-module-file-spec-functions bash python" |
164 | 168 | ||
165 | BBCLASSEXTEND = "native nativesdk" | 169 | BBCLASSEXTEND = "native nativesdk" |