diff options
author | Ovidiu Panait <ovidiu.panait@windriver.com> | 2017-12-20 13:15:37 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-07-09 22:48:39 +0100 |
commit | f9ad66da9f3825d6f534b5111f9bc131af7d0483 (patch) | |
tree | c61f33d1dc7f6699be015aaa9df11807f82b5e7f /meta/recipes-connectivity/openssl/openssl_1.1.0h.bb | |
parent | fbf465c07d12ae7f7822e6961f8cf61fd5f14e56 (diff) | |
download | poky-f9ad66da9f3825d6f534b5111f9bc131af7d0483.tar.gz |
openssl-nativesdk: Fix "can't open config file" warning
When SDK is not installed in the default location, openssl will not be
able to find the the openssl.cnf config file:
"WARNING: can't open config file: XXXX/usr/lib/ssl/openssl.cnf"
To fix this, we need to provide the environment variable $OPENSSL_CONF
pointing to the correct config file location.
(From OE-Core rev: b3f148333515efdb746b78c57d62cfbf3321b21e)
Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.1.0h.bb')
-rw-r--r-- | meta/recipes-connectivity/openssl/openssl_1.1.0h.bb | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb index 94b75eb92a..29f83a31a2 100644 --- a/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb +++ b/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb | |||
@@ -19,6 +19,10 @@ SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \ | |||
19 | file://0001-Take-linking-flags-from-LDFLAGS-env-var.patch \ | 19 | file://0001-Take-linking-flags-from-LDFLAGS-env-var.patch \ |
20 | " | 20 | " |
21 | 21 | ||
22 | SRC_URI_append_class-nativesdk = " \ | ||
23 | file://environment.d-openssl.sh \ | ||
24 | " | ||
25 | |||
22 | S = "${WORKDIR}/openssl-${PV}" | 26 | S = "${WORKDIR}/openssl-${PV}" |
23 | 27 | ||
24 | inherit lib_package multilib_header ptest | 28 | inherit lib_package multilib_header ptest |
@@ -142,6 +146,13 @@ do_install_append_class-native () { | |||
142 | sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash | 146 | sed -i -e 's,/etc/openssl,${sysconfdir}/ssl,g' ${D}${bindir}/c_rehash |
143 | } | 147 | } |
144 | 148 | ||
149 | do_install_append_class-nativesdk() { | ||
150 | mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d | ||
151 | install -m 644 ${WORKDIR}/environment.d-openssl.sh ${D}${SDKPATHNATIVE}/environment-setup.d/openssl.sh | ||
152 | } | ||
153 | |||
154 | FILES_${PN}_append_class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/openssl.sh" | ||
155 | |||
145 | do_install_ptest() { | 156 | do_install_ptest() { |
146 | cp -r * ${D}${PTEST_PATH} | 157 | cp -r * ${D}${PTEST_PATH} |
147 | 158 | ||