summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.1.0g.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2018-03-09 11:55:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-03 09:53:48 +0100
commit26f09806b8a2456719dd754a460b6bb9c8e3c211 (patch)
treeb19a153b177c6694ecd7d93f88029cb65614aba5 /meta/recipes-connectivity/openssl/openssl_1.1.0g.bb
parentfea202bf7657a479be32e4e7a30396fce58eac29 (diff)
downloadpoky-26f09806b8a2456719dd754a460b6bb9c8e3c211.tar.gz
openssl: fix libdir logic to allow multiarch style paths
The recipes were using 'basename' to turn '/usr/lib' into 'lib', which breaks when libdir is '/usr/lib/tuple', leading to libraries ending up in '/usr/tuple', which isn't in FILES_*. Change the logic to use sed to strip the prefix instead. (From OE-Core rev: e58d5521c7bae8daafdac85754545be176550a02) (From OE-Core rev: 373763d4f6668c3e324edf8d699c8c15d0267278) Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.1.0g.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.0g.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0g.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0g.bb
index 1649bffaa1..4cc5edcadc 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.0g.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.0g.bb
@@ -110,7 +110,8 @@ do_configure () {
110 if [ "x$useprefix" = "x" ]; then 110 if [ "x$useprefix" = "x" ]; then
111 useprefix=/ 111 useprefix=/
112 fi 112 fi
113 perl ./Configure ${EXTRA_OECONF} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=`basename ${libdir}` $target 113 libdirleaf="$(echo ${libdir} | sed s:$useprefix::)"
114 perl ./Configure ${EXTRA_OECONF} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=${libdirleaf} $target
114} 115}
115 116
116#| engines/afalg/e_afalg.c: In function 'eventfd': 117#| engines/afalg/e_afalg.c: In function 'eventfd':