diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2018-07-28 13:39:22 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-29 15:23:50 +0100 |
commit | 6b3f4c8a661f67387a3716905c767375ff7ce0bd (patch) | |
tree | 3d2f4f1059c9c2f1676b1bfdd2c05ff6f0136bb2 /meta/recipes-connectivity/openssl/openssl_1.0.2o.bb | |
parent | d62b399d6fb6c2301864d6d0c131ecccc810cdf9 (diff) | |
download | poky-6b3f4c8a661f67387a3716905c767375ff7ce0bd.tar.gz |
openssl_1.0: add PACKAGECONFIG option to control manpages
Creating the openssl manpages, which happens as part of do_install(),
can take a significant amount of time (e.g. ~50 seconds on a quad
core laptop). Provide a PACKAGECONFIG option to allow creation of the
manpages to be skipped completely if not required and inherit the
manpages class to automatically control the PACKAGECONFIG option
(based on the "api-documentation" distro feature).
(From OE-Core rev: 1ddca1872f64c566fd812a6ec44f2d4e4d84f58f)
(From OE-Core rev: 061c17ff22f4df573bccbf4b66f2fdf5501c3617)
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2o.bb')
-rw-r--r-- | meta/recipes-connectivity/openssl/openssl_1.0.2o.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb index 2804203e38..bbce14fe6b 100644 --- a/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb +++ b/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb | |||
@@ -43,6 +43,7 @@ SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \ | |||
43 | file://Use-SHA256-not-MD5-as-default-digest.patch \ | 43 | file://Use-SHA256-not-MD5-as-default-digest.patch \ |
44 | file://0001-Fix-build-with-clang-using-external-assembler.patch \ | 44 | file://0001-Fix-build-with-clang-using-external-assembler.patch \ |
45 | file://0001-openssl-force-soft-link-to-avoid-rare-race.patch \ | 45 | file://0001-openssl-force-soft-link-to-avoid-rare-race.patch \ |
46 | file://0001-allow-manpages-to-be-disabled.patch \ | ||
46 | " | 47 | " |
47 | 48 | ||
48 | SRC_URI_append_class-target = " \ | 49 | SRC_URI_append_class-target = " \ |
@@ -59,19 +60,22 @@ SRC_URI[sha256sum] = "ec3f5c9714ba0fd45cb4e087301eb1336c317e0d20b575a125050470e8 | |||
59 | 60 | ||
60 | UPSTREAM_CHECK_REGEX = "openssl-(?P<pver>1\.0.+)\.tar" | 61 | UPSTREAM_CHECK_REGEX = "openssl-(?P<pver>1\.0.+)\.tar" |
61 | 62 | ||
62 | inherit pkgconfig siteinfo multilib_header ptest relative_symlinks | 63 | inherit pkgconfig siteinfo multilib_header ptest relative_symlinks manpages |
63 | 64 | ||
64 | PACKAGECONFIG ?= "cryptodev-linux" | 65 | PACKAGECONFIG ?= "cryptodev-linux" |
65 | PACKAGECONFIG_class-native = "" | 66 | PACKAGECONFIG_class-native = "" |
66 | PACKAGECONFIG_class-nativesdk = "" | 67 | PACKAGECONFIG_class-nativesdk = "" |
67 | 68 | ||
68 | PACKAGECONFIG[perl] = ",,," | ||
69 | PACKAGECONFIG[cryptodev-linux] = "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS,,cryptodev-linux" | 69 | PACKAGECONFIG[cryptodev-linux] = "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS,,cryptodev-linux" |
70 | PACKAGECONFIG[manpages] = ",,," | ||
71 | PACKAGECONFIG[perl] = ",,," | ||
70 | 72 | ||
71 | # Remove this to enable SSLv3. SSLv3 is defaulted to disabled due to the POODLE | 73 | # Remove this to enable SSLv3. SSLv3 is defaulted to disabled due to the POODLE |
72 | # vulnerability | 74 | # vulnerability |
73 | EXTRA_OECONF = "no-ssl3" | 75 | EXTRA_OECONF = "no-ssl3" |
74 | 76 | ||
77 | EXTRA_OEMAKE = "${@bb.utils.contains('PACKAGECONFIG', 'manpages', '', 'OE_DISABLE_MANPAGES=1', d)}" | ||
78 | |||
75 | export OE_LDFLAGS = "${LDFLAGS}" | 79 | export OE_LDFLAGS = "${LDFLAGS}" |
76 | 80 | ||
77 | # openssl fails with ccache: https://bugzilla.yoctoproject.org/show_bug.cgi?id=12810 | 81 | # openssl fails with ccache: https://bugzilla.yoctoproject.org/show_bug.cgi?id=12810 |