summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-06-18 15:23:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-06 14:38:13 +0100
commitd9cb7e713970452d0bd8f46418c82110c7acfe37 (patch)
tree0fb5a50ae4cef8a9dc11b7c077d10f6d3f0236e4 /meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
parent838c5ba5bec907bd69875e690d8996d14f636c89 (diff)
downloadpoky-d9cb7e713970452d0bd8f46418c82110c7acfe37.tar.gz
openssl: Upgrade 1.0.2k -> 1.0.2l
1. Dropped obsolete patches, because the new version contains them: - fix-cipher-des-ede3-cfb1.patch - openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch 2. LICENSE checksum change due to copyright years and wording tweak. 3. Test binaries (x86-64) are included in source code. So remove those only for ptest. (From OE-Core rev: 64ec18d7e13d310e5e44080a04b3f2181ea96ae3) Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2l.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2l.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
new file mode 100644
index 0000000000..a2ef2ac8fb
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
@@ -0,0 +1,60 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8CFLAG_append_class-native = " -fPIC"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=057d9218c6180e1d9ee407572b2dd225"
11
12export DIRS = "crypto ssl apps engines"
13export OE_LDFLAGS="${LDFLAGS}"
14
15SRC_URI += "file://find.pl;subdir=${BP}/util/ \
16 file://run-ptest \
17 file://openssl-c_rehash.sh \
18 file://configure-targets.patch \
19 file://shared-libs.patch \
20 file://oe-ldflags.patch \
21 file://engines-install-in-libdir-ssl.patch \
22 file://debian1.0.2/block_diginotar.patch \
23 file://debian1.0.2/block_digicert_malaysia.patch \
24 file://debian/ca.patch \
25 file://debian/c_rehash-compat.patch \
26 file://debian/debian-targets.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-rpath.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/pic.patch \
32 file://debian1.0.2/version-script.patch \
33 file://debian1.0.2/soname.patch \
34 file://openssl_fix_for_x32.patch \
35 file://openssl-fix-des.pod-error.patch \
36 file://Makefiles-ptest.patch \
37 file://ptest-deps.patch \
38 file://openssl-1.0.2a-x32-asm.patch \
39 file://ptest_makefile_deps.patch \
40 file://configure-musl-target.patch \
41 file://parallel.patch \
42 file://openssl-util-perlpath.pl-cwd.patch \
43 file://Use-SHA256-not-MD5-as-default-digest.patch \
44 file://0001-Fix-build-with-clang-using-external-assembler.patch \
45 "
46SRC_URI[md5sum] = "f85123cd390e864dfbe517e7616e6566"
47SRC_URI[sha256sum] = "ce07195b659e75f4e1db43552860070061f156a98bb37b672b101ba6e3ddf30c"
48
49PACKAGES =+ "${PN}-engines"
50FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
51
52# The crypto_use_bigint patch means that perl's bignum module needs to be
53# installed, but some distributions (for example Fedora 23) don't ship it by
54# default. As the resulting error is very misleading check for bignum before
55# building.
56do_configure_prepend() {
57 if ! perl -Mbigint -e true; then
58 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
59 fi
60}