summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-08-18 22:31:29 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-19 22:15:39 +0100
commit7a4361c506ac24bafcf294f498d00278f11c3bd4 (patch)
tree56bbceaba0356a4e447fcdc63d4d35a542629749 /meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
parent05a67104676e192e959150eb49902bed82681545 (diff)
downloadpoky-7a4361c506ac24bafcf294f498d00278f11c3bd4.tar.gz
openssl10: rename back to openssl and make it the default via PREFERRED_VERSION
openssl 1.1 broke 3rd party layers a lot more than was expected; let's flip the switch at the start of next development cycle. Add a PROVIDES = "openssl10" to openssl 1.0 recipe; any dependency that is not compatible with 1.1 should use that in its DEPENDS, as the 1.0 recipe will later be renamed back to openssl10. This does not always work: http://lists.openembedded.org/pipermail/openembedded-core/2017-August/140957.html but for many recipes it does. (From OE-Core rev: 5585103c195104e85ed7ac1455bef91b2e88a04d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2l.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2l.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
new file mode 100644
index 0000000000..8c34ea60e5
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2l.bb
@@ -0,0 +1,59 @@
1require openssl10.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5
6CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
7CFLAG_append_class-native = " -fPIC"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=057d9218c6180e1d9ee407572b2dd225"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://find.pl;subdir=openssl-${PV}/util/ \
15 file://run-ptest \
16 file://openssl-c_rehash.sh \
17 file://configure-targets.patch \
18 file://shared-libs.patch \
19 file://oe-ldflags.patch \
20 file://engines-install-in-libdir-ssl.patch \
21 file://debian1.0.2/block_diginotar.patch \
22 file://debian1.0.2/block_digicert_malaysia.patch \
23 file://debian/ca.patch \
24 file://debian/c_rehash-compat.patch \
25 file://debian/debian-targets.patch \
26 file://debian/man-dir.patch \
27 file://debian/man-section.patch \
28 file://debian/no-rpath.patch \
29 file://debian/no-symbolic.patch \
30 file://debian/pic.patch \
31 file://debian1.0.2/version-script.patch \
32 file://debian1.0.2/soname.patch \
33 file://openssl_fix_for_x32.patch \
34 file://openssl-fix-des.pod-error.patch \
35 file://Makefiles-ptest.patch \
36 file://ptest-deps.patch \
37 file://openssl-1.0.2a-x32-asm.patch \
38 file://ptest_makefile_deps.patch \
39 file://configure-musl-target.patch \
40 file://parallel.patch \
41 file://openssl-util-perlpath.pl-cwd.patch \
42 file://Use-SHA256-not-MD5-as-default-digest.patch \
43 file://0001-Fix-build-with-clang-using-external-assembler.patch \
44 "
45SRC_URI[md5sum] = "f85123cd390e864dfbe517e7616e6566"
46SRC_URI[sha256sum] = "ce07195b659e75f4e1db43552860070061f156a98bb37b672b101ba6e3ddf30c"
47
48PACKAGES =+ "${PN}-engines"
49FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
50
51# The crypto_use_bigint patch means that perl's bignum module needs to be
52# installed, but some distributions (for example Fedora 23) don't ship it by
53# default. As the resulting error is very misleading check for bignum before
54# building.
55do_configure_prepend() {
56 if ! perl -Mbigint -e true; then
57 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
58 fi
59}