diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2012-06-16 08:43:35 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-21 13:03:02 +0100 |
commit | e56205257bbb3b1eab352b9d50fc52c920afd9b1 (patch) | |
tree | 72834070d3ea622fa2186fa3d7d3116fddfe9b2e /meta/recipes-connectivity/openssl/openssl_1.0.0i.bb | |
parent | 262e5ac4bc98b19b222d56a788832d268bc8b114 (diff) | |
download | poky-e56205257bbb3b1eab352b9d50fc52c920afd9b1.tar.gz |
openssl: add deprecated and unmaintained find.pl from perl-5.14 to fix perlpath.pl
* openembedded-core/meta/recipes-connectivity/openssl/openssl.inc
*
* is using perlpath.pl:
*
* do_configure () {
* cd util
* perl perlpath.pl ${STAGING_BINDIR_NATIVE}
* ...
*
* and perlpath.pl is using find.pl:
* openssl-1.0.0i/util/perlpath.pl:
* #!/usr/local/bin/perl
* #
* # modify the '#!/usr/local/bin/perl'
* # line in all scripts that rely on perl.
* #
*
* require "find.pl";
* ...
*
* which was removed in perl-5.16.0 and marked as deprecated and
* unmaintained in 5.14 and older:
* /tmp/usr/lib/perl5/5.14.2/find.pl:
* warn "Legacy library @{[(caller(0))[6]]} will be removed from the Perl
* core distribution in the next major release. Please install it from the
* CPAN distribution Perl4::CoreLibs. It is being used at @{[(caller)[1]]},
* line @{[(caller)[2]]}.\n";
*
* # This library is deprecated and unmaintained. It is included for
* # compatibility with Perl 4 scripts which may use it, but it will be
* # removed in a future version of Perl. Please use the File::Find module
* # instead.
(From OE-Core rev: c09bf5d177a7ecd2045ef7e13fff4528137a9775)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.0i.bb')
-rw-r--r-- | meta/recipes-connectivity/openssl/openssl_1.0.0i.bb | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb b/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb index ca15a3843e..c233ba1546 100644 --- a/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb +++ b/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb | |||
@@ -6,7 +6,7 @@ DEPENDS += "ocf-linux" | |||
6 | 6 | ||
7 | CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" | 7 | CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" |
8 | 8 | ||
9 | PR = "${INC_PR}.2" | 9 | PR = "${INC_PR}.3" |
10 | 10 | ||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" |
12 | 12 | ||
@@ -29,6 +29,7 @@ SRC_URI += "file://configure-targets.patch \ | |||
29 | file://debian/no-symbolic.patch \ | 29 | file://debian/no-symbolic.patch \ |
30 | file://debian/debian-targets.patch \ | 30 | file://debian/debian-targets.patch \ |
31 | file://openssl_fix_for_x32.patch \ | 31 | file://openssl_fix_for_x32.patch \ |
32 | file://find.pl \ | ||
32 | " | 33 | " |
33 | 34 | ||
34 | SRC_URI[md5sum] = "b4df9c11af454fd68178c85a1d5f328f" | 35 | SRC_URI[md5sum] = "b4df9c11af454fd68178c85a1d5f328f" |
@@ -43,3 +44,7 @@ FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines" | |||
43 | FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug" | 44 | FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug" |
44 | 45 | ||
45 | PARALLEL_MAKEINST = "" | 46 | PARALLEL_MAKEINST = "" |
47 | |||
48 | do_configure_prepend() { | ||
49 | cp ${WORKDIR}/find.pl ${S}/util/find.pl | ||
50 | } | ||