diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-05-09 17:02:39 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-05-21 12:08:04 +0100 |
commit | 71c6db8e65ced98db74fd18b726fa4b4c0346f05 (patch) | |
tree | 0e5d7f21a2d65ba5b562068eb44d4e9b34465bed /meta/recipes-connectivity/openssh/openssh_9.7p1.bb | |
parent | c6c1ed6ba0b7e529d955eeda71c4a66317fa1331 (diff) | |
download | poky-71c6db8e65ced98db74fd18b726fa4b4c0346f05.tar.gz |
recipes: Start WORKDIR -> UNPACKDIR transition
Replace references of WORKDIR with UNPACKDIR where it makes sense to do
so in preparation for changing the default value of UNPACKDIR.
(From OE-Core rev: 1f18b9a512800860d5153d89eb82b56388efad6f)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_9.7p1.bb')
-rw-r--r-- | meta/recipes-connectivity/openssh/openssh_9.7p1.bb | 16 |
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_9.7p1.bb b/meta/recipes-connectivity/openssh/openssh_9.7p1.bb index 36ffa49398..82da92f63f 100644 --- a/meta/recipes-connectivity/openssh/openssh_9.7p1.bb +++ b/meta/recipes-connectivity/openssh/openssh_9.7p1.bb | |||
@@ -112,7 +112,7 @@ do_compile_ptest() { | |||
112 | 112 | ||
113 | do_install:append () { | 113 | do_install:append () { |
114 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then | 114 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then |
115 | install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd | 115 | install -D -m 0644 ${UNPACKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd |
116 | sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config | 116 | sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config |
117 | fi | 117 | fi |
118 | 118 | ||
@@ -121,11 +121,11 @@ do_install:append () { | |||
121 | fi | 121 | fi |
122 | 122 | ||
123 | install -d ${D}${sysconfdir}/init.d | 123 | install -d ${D}${sysconfdir}/init.d |
124 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd | 124 | install -m 0755 ${UNPACKDIR}/init ${D}${sysconfdir}/init.d/sshd |
125 | rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin | 125 | rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin |
126 | rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir} | 126 | rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir} |
127 | install -d ${D}/${sysconfdir}/default/volatiles | 127 | install -d ${D}/${sysconfdir}/default/volatiles |
128 | install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd | 128 | install -m 644 ${UNPACKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd |
129 | install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir} | 129 | install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir} |
130 | 130 | ||
131 | # Create config files for read-only rootfs | 131 | # Create config files for read-only rootfs |
@@ -138,8 +138,8 @@ do_install:append () { | |||
138 | 138 | ||
139 | install -d ${D}${systemd_system_unitdir} | 139 | install -d ${D}${systemd_system_unitdir} |
140 | if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','true','false',d)}; then | 140 | if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','true','false',d)}; then |
141 | install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_system_unitdir} | 141 | install -c -m 0644 ${UNPACKDIR}/sshd.socket ${D}${systemd_system_unitdir} |
142 | install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_system_unitdir} | 142 | install -c -m 0644 ${UNPACKDIR}/sshd@.service ${D}${systemd_system_unitdir} |
143 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | 143 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
144 | -e 's,@SBINDIR@,${sbindir},g' \ | 144 | -e 's,@SBINDIR@,${sbindir},g' \ |
145 | -e 's,@BINDIR@,${bindir},g' \ | 145 | -e 's,@BINDIR@,${bindir},g' \ |
@@ -147,9 +147,9 @@ do_install:append () { | |||
147 | ${D}${systemd_system_unitdir}/sshd.socket | 147 | ${D}${systemd_system_unitdir}/sshd.socket |
148 | fi | 148 | fi |
149 | if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','true','false',d)}; then | 149 | if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','true','false',d)}; then |
150 | install -c -m 0644 ${WORKDIR}/sshd.service ${D}${systemd_system_unitdir} | 150 | install -c -m 0644 ${UNPACKDIR}/sshd.service ${D}${systemd_system_unitdir} |
151 | fi | 151 | fi |
152 | install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_system_unitdir} | 152 | install -c -m 0644 ${UNPACKDIR}/sshdgenkeys.service ${D}${systemd_system_unitdir} |
153 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | 153 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
154 | -e 's,@SBINDIR@,${sbindir},g' \ | 154 | -e 's,@SBINDIR@,${sbindir},g' \ |
155 | -e 's,@BINDIR@,${bindir},g' \ | 155 | -e 's,@BINDIR@,${bindir},g' \ |
@@ -159,7 +159,7 @@ do_install:append () { | |||
159 | sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \ | 159 | sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \ |
160 | ${D}${sysconfdir}/init.d/sshd | 160 | ${D}${sysconfdir}/init.d/sshd |
161 | 161 | ||
162 | install -D -m 0755 ${WORKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys | 162 | install -D -m 0755 ${UNPACKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys |
163 | } | 163 | } |
164 | 164 | ||
165 | do_install_ptest () { | 165 | do_install_ptest () { |