summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh/openssh_6.4p1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-01-16 22:03:22 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:52:31 +0000
commitdbfcfbfeb28a3257c629e6ebaf3399da4b7aa087 (patch)
treee649f2354d5b688a6b21f013c9020478d80fc95d /meta/recipes-connectivity/openssh/openssh_6.4p1.bb
parentab2e677df0a95dc52b32401fa77f63710f346c54 (diff)
downloadpoky-dbfcfbfeb28a3257c629e6ebaf3399da4b7aa087.tar.gz
openssh: fixes for systemd
This patch contains a few fixes for the systemd unit files of openssh. The fixes use the same unit files in Fedora 20 as a reference. 1) Remove sshdgenkeys.service and sshd@.service from SYSTEMD_SERVICE. 2) Fix the dependency and logic of sshdgenkeys.service. (From OE-Core rev: 4379e6f3096c893db5fa6a0b4569a0440e4494fe) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_6.4p1.bb')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_6.4p1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.4p1.bb b/meta/recipes-connectivity/openssh/openssh_6.4p1.bb
index c61d16f6c6..1f78566c6c 100644
--- a/meta/recipes-connectivity/openssh/openssh_6.4p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_6.4p1.bb
@@ -44,7 +44,7 @@ INITSCRIPT_NAME_${PN}-sshd = "sshd"
44INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9" 44INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9"
45 45
46SYSTEMD_PACKAGES = "${PN}-sshd" 46SYSTEMD_PACKAGES = "${PN}-sshd"
47SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket sshd@.service sshdgenkeys.service" 47SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
48 48
49PACKAGECONFIG ??= "tcp-wrappers" 49PACKAGECONFIG ??= "tcp-wrappers"
50PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers" 50PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers"
@@ -114,7 +114,7 @@ ALLOW_EMPTY_${PN} = "1"
114PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server" 114PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
115FILES_${PN}-scp = "${bindir}/scp.${BPN}" 115FILES_${PN}-scp = "${bindir}/scp.${BPN}"
116FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config" 116FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
117FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd" 117FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_unitdir}/system"
118FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd" 118FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd"
119FILES_${PN}-sftp = "${bindir}/sftp" 119FILES_${PN}-sftp = "${bindir}/sftp"
120FILES_${PN}-sftp-server = "${libexecdir}/sftp-server" 120FILES_${PN}-sftp-server = "${libexecdir}/sftp-server"