diff options
author | Andrei Dinu <andrei.adrianx.dinu@intel.com> | 2013-01-28 10:50:04 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-01-28 14:49:04 +0000 |
commit | f3dfb7c200389e08a362737fa27546e704907f0a (patch) | |
tree | b002c69c90babce09bbd3f6b55e0b7cc83cfce35 /meta/recipes-connectivity/openssh/openssh_6.1p1.bb | |
parent | 3ba2ce25bdc78f660552d3d16272a551d434c527 (diff) | |
download | poky-f3dfb7c200389e08a362737fa27546e704907f0a.tar.gz |
openssh : upgrade to 6.1p1
(From OE-Core rev: 5534deb69b0a2835fbbf149a00d1f6ba61cc8160)
Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_6.1p1.bb')
-rw-r--r-- | meta/recipes-connectivity/openssh/openssh_6.1p1.bb | 107 |
1 files changed, 107 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.1p1.bb b/meta/recipes-connectivity/openssh/openssh_6.1p1.bb new file mode 100644 index 0000000000..71d71e4464 --- /dev/null +++ b/meta/recipes-connectivity/openssh/openssh_6.1p1.bb | |||
@@ -0,0 +1,107 @@ | |||
1 | SUMMARY = "Secure rlogin/rsh/rcp/telnet replacement" | ||
2 | DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \ | ||
3 | Ssh (Secure Shell) is a program for logging into a remote machine \ | ||
4 | and for executing commands on a remote machine." | ||
5 | HOMEPAGE = "http://openssh.org" | ||
6 | SECTION = "console/network" | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=e326045657e842541d3f35aada442507" | ||
9 | |||
10 | PR = "r0" | ||
11 | |||
12 | DEPENDS = "zlib openssl" | ||
13 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
14 | |||
15 | RPROVIDES = "ssh sshd" | ||
16 | |||
17 | RCONFLICTS_${PN} = "dropbear" | ||
18 | RCONFLICTS_${PN}-sshd = "dropbear" | ||
19 | RCONFLICTS_${PN}-keygen = "ssh-keygen" | ||
20 | |||
21 | SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \ | ||
22 | file://nostrip.patch \ | ||
23 | file://sshd_config \ | ||
24 | file://ssh_config \ | ||
25 | file://init \ | ||
26 | file://openssh-CVE-2011-4327.patch \ | ||
27 | ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" | ||
28 | |||
29 | PAM_SRC_URI = "file://sshd" | ||
30 | |||
31 | SRC_URI[md5sum] = "3345cbf4efe90ffb06a78670ab2d05d5" | ||
32 | SRC_URI[sha256sum] = "d1c157f6c0852e90c191cc7c9018a583b51e3db4035489cb262639d337a1c411" | ||
33 | inherit useradd update-rc.d update-alternatives | ||
34 | |||
35 | USERADD_PACKAGES = "${PN}-sshd" | ||
36 | USERADD_PARAM_${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd" | ||
37 | INITSCRIPT_PACKAGES = "${PN}-sshd" | ||
38 | INITSCRIPT_NAME_${PN}-sshd = "sshd" | ||
39 | INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9" | ||
40 | |||
41 | inherit autotools | ||
42 | |||
43 | # LFS support: | ||
44 | CFLAGS += "-D__FILE_OFFSET_BITS=64" | ||
45 | export LD = "${CC}" | ||
46 | |||
47 | EXTRA_OECONF = "--with-rand-helper=no \ | ||
48 | ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \ | ||
49 | --without-zlib-version-check \ | ||
50 | --with-privsep-path=/var/run/sshd \ | ||
51 | --sysconfdir=${sysconfdir}/ssh \ | ||
52 | --with-xauth=/usr/bin/xauth" | ||
53 | |||
54 | # This is a workaround for uclibc because including stdio.h | ||
55 | # pulls in pthreads.h and causes conflicts in function prototypes. | ||
56 | # This results in compilation failure, so unless this is fixed, | ||
57 | # disable pam for uclibc. | ||
58 | EXTRA_OECONF_append_libc-uclibc=" --without-pam" | ||
59 | |||
60 | do_configure_prepend () { | ||
61 | if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then | ||
62 | cp aclocal.m4 acinclude.m4 | ||
63 | fi | ||
64 | } | ||
65 | |||
66 | do_compile_append () { | ||
67 | install -m 0644 ${WORKDIR}/sshd_config ${S}/ | ||
68 | install -m 0644 ${WORKDIR}/ssh_config ${S}/ | ||
69 | } | ||
70 | |||
71 | do_install_append () { | ||
72 | for i in ${DISTRO_FEATURES}; | ||
73 | do | ||
74 | if [ ${i} = "pam" ]; then | ||
75 | install -d ${D}${sysconfdir}/pam.d | ||
76 | install -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd | ||
77 | fi | ||
78 | done | ||
79 | install -d ${D}${sysconfdir}/init.d | ||
80 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd | ||
81 | rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin | ||
82 | rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir} | ||
83 | } | ||
84 | |||
85 | ALLOW_EMPTY_${PN} = "1" | ||
86 | |||
87 | PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server" | ||
88 | FILES_${PN}-scp = "${bindir}/scp.${BPN}" | ||
89 | FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config" | ||
90 | FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd" | ||
91 | FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config" | ||
92 | FILES_${PN}-sftp = "${bindir}/sftp" | ||
93 | FILES_${PN}-sftp-server = "${libexecdir}/sftp-server" | ||
94 | FILES_${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*" | ||
95 | FILES_${PN}-keygen = "${bindir}/ssh-keygen" | ||
96 | |||
97 | RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen" | ||
98 | DEPENDS_${PN}-sshd += "update-rc.d" | ||
99 | RDEPENDS_${PN}-sshd += "update-rc.d ${PN}-keygen" | ||
100 | |||
101 | CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config" | ||
102 | CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config" | ||
103 | |||
104 | ALTERNATIVE_PRIORITY = "90" | ||
105 | ALTERNATIVE_${PN}-scp = "scp" | ||
106 | ALTERNATIVE_${PN}-ssh = "ssh" | ||
107 | |||