diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2015-12-14 15:59:29 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-12-16 12:12:17 +0000 |
commit | 516d8c9759d18952869e7b1045a0fcd880cca1bc (patch) | |
tree | 73c1a8e8ff253a24bcb48db4e3c380ecbd78cbdd /meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb | |
parent | 9c39a4f9cd5e54428aa0df7fdf7cbb7e7256f92d (diff) | |
download | poky-516d8c9759d18952869e7b1045a0fcd880cca1bc.tar.gz |
nfs-utils: update to 1.3.3
ipv6 support now requires libtirpc, so un-disable and add it to dependencies.
(From OE-Core rev: 219d74d9df6a4a819d03091f35205a5634b268c7)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb')
-rw-r--r-- | meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb | 141 |
1 files changed, 141 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb new file mode 100644 index 0000000000..2e0c8b1913 --- /dev/null +++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.3.bb | |||
@@ -0,0 +1,141 @@ | |||
1 | SUMMARY = "userspace utilities for kernel nfs" | ||
2 | DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \ | ||
3 | NFS server and related tools." | ||
4 | HOMEPAGE = "http://nfs.sourceforge.net/" | ||
5 | SECTION = "console/network" | ||
6 | |||
7 | LICENSE = "MIT & GPLv2+ & BSD" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84" | ||
9 | |||
10 | # util-linux for libblkid | ||
11 | DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3 libtirpc" | ||
12 | RDEPENDS_${PN}-client = "rpcbind bash" | ||
13 | RDEPENDS_${PN} = "${PN}-client bash" | ||
14 | RRECOMMENDS_${PN} = "kernel-module-nfsd" | ||
15 | |||
16 | inherit useradd | ||
17 | |||
18 | USERADD_PACKAGES = "${PN}-client" | ||
19 | USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \ | ||
20 | --shell /bin/false --user-group rpcuser" | ||
21 | |||
22 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \ | ||
23 | file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \ | ||
24 | file://nfs-utils-1.2.3-sm-notify-res_init.patch \ | ||
25 | file://nfsserver \ | ||
26 | file://nfscommon \ | ||
27 | file://nfs-utils.conf \ | ||
28 | file://nfs-server.service \ | ||
29 | file://nfs-mountd.service \ | ||
30 | file://nfs-statd.service \ | ||
31 | file://proc-fs-nfsd.mount \ | ||
32 | file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \ | ||
33 | file://nfs-utils-debianize-start-statd.patch \ | ||
34 | file://0001-nfs-utils-statd-fix-a-segfault-caused-by-improper-us.patch \ | ||
35 | " | ||
36 | |||
37 | SRC_URI[md5sum] = "cd6b568c2e9301cc3bfac09d87fbbc0b" | ||
38 | SRC_URI[sha256sum] = "700d689c5622c87953c34102e5befafc4d3c811e676852238f0dd79c9c0c084d" | ||
39 | |||
40 | # Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will | ||
41 | # pull in the remainder of the dependencies. | ||
42 | |||
43 | INITSCRIPT_PACKAGES = "${PN} ${PN}-client" | ||
44 | INITSCRIPT_NAME = "nfsserver" | ||
45 | INITSCRIPT_PARAMS = "defaults" | ||
46 | INITSCRIPT_NAME_${PN}-client = "nfscommon" | ||
47 | INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21" | ||
48 | |||
49 | inherit autotools-brokensep update-rc.d systemd pkgconfig | ||
50 | |||
51 | SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service" | ||
52 | SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service" | ||
53 | SYSTEMD_AUTO_ENABLE = "disable" | ||
54 | |||
55 | # --enable-uuid is need for cross-compiling | ||
56 | EXTRA_OECONF = "--with-statduser=rpcuser \ | ||
57 | --enable-mountconfig \ | ||
58 | --enable-libmount-mount \ | ||
59 | --disable-nfsv41 \ | ||
60 | --enable-uuid \ | ||
61 | --disable-gss \ | ||
62 | --disable-nfsdcltrack \ | ||
63 | --with-statdpath=/var/lib/nfs/statd \ | ||
64 | " | ||
65 | |||
66 | PACKAGECONFIG ??= "tcp-wrappers" | ||
67 | PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers" | ||
68 | PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils" | ||
69 | |||
70 | INHIBIT_AUTO_STAGE = "1" | ||
71 | |||
72 | PACKAGES =+ "${PN}-client ${PN}-stats" | ||
73 | |||
74 | CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \ | ||
75 | ${localstatedir}/lib/nfs/rmtab \ | ||
76 | ${localstatedir}/lib/nfs/xtab \ | ||
77 | ${localstatedir}/lib/nfs/statd/state \ | ||
78 | ${sysconfdir}/nfsmount.conf" | ||
79 | |||
80 | FILES_${PN}-client = "${base_sbindir}/*mount.nfs* ${sbindir}/*statd \ | ||
81 | ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \ | ||
82 | ${sbindir}/showmount ${sbindir}/nfsstat \ | ||
83 | ${localstatedir}/lib/nfs \ | ||
84 | ${sysconfdir}/nfs-utils.conf \ | ||
85 | ${sysconfdir}/nfsmount.conf \ | ||
86 | ${sysconfdir}/init.d/nfscommon \ | ||
87 | ${systemd_unitdir}/system/nfs-statd.service" | ||
88 | FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat" | ||
89 | RDEPENDS_${PN}-stats = "python" | ||
90 | |||
91 | FILES_${PN} += "${systemd_unitdir}" | ||
92 | |||
93 | do_configure_prepend() { | ||
94 | sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \ | ||
95 | ${S}/utils/mount/Makefile.am | ||
96 | |||
97 | sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \ | ||
98 | ${S}/utils/osd_login/Makefile.am | ||
99 | } | ||
100 | |||
101 | # Make clean needed because the package comes with | ||
102 | # precompiled 64-bit objects that break the build | ||
103 | do_compile_prepend() { | ||
104 | make clean | ||
105 | } | ||
106 | |||
107 | do_install_append () { | ||
108 | install -d ${D}${sysconfdir}/init.d | ||
109 | install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver | ||
110 | install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon | ||
111 | |||
112 | install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir} | ||
113 | install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir} | ||
114 | |||
115 | install -d ${D}${systemd_unitdir}/system | ||
116 | install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/ | ||
117 | install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/ | ||
118 | install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/ | ||
119 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ | ||
120 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | ||
121 | ${D}${systemd_unitdir}/system/*.service | ||
122 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
123 | install -d ${D}${sysconfdir}/modules-load.d | ||
124 | echo "nfsd" > ${D}${sysconfdir}/modules-load.d/nfsd.conf | ||
125 | install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/ | ||
126 | install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/ | ||
127 | ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount | ||
128 | fi | ||
129 | |||
130 | # kernel code as of 3.8 hard-codes this path as a default | ||
131 | install -d ${D}/var/lib/nfs/v4recovery | ||
132 | |||
133 | # chown the directories and files | ||
134 | chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd | ||
135 | chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state | ||
136 | |||
137 | # the following are built by CC_FOR_BUILD | ||
138 | rm -f ${D}${sbindir}/rpcdebug | ||
139 | rm -f ${D}${sbindir}/rpcgen | ||
140 | rm -f ${D}${sbindir}/locktest | ||
141 | } | ||