summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb
diff options
context:
space:
mode:
authorZhang Xiao <xiao.zhang@windriver.com>2013-11-21 16:07:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-09 18:01:44 +0000
commitc0e048d33d5a5557ba24d74751aca7b000b16649 (patch)
tree533a51c9342854a62bb3ee62f9575d924e8d9441 /meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb
parentfedd84f7eee7dba095459cde4df435975c7e6aac (diff)
downloadpoky-c0e048d33d5a5557ba24d74751aca7b000b16649.tar.gz
nfs-utils: separate package as Debain style
Move binaries used for both nfs client and server into client package. Add an init script for client package and move necessary progress from server's init script to this one. Make client package more powerful and let server package depends on client one, as Debain does. (From OE-Core rev: 39bb7e32c5eb930981392cec70a063e8dac152b7) Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb27
1 files changed, 21 insertions, 6 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb
index ea4914670b..cbfb7c1331 100644
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb
@@ -9,14 +9,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9 9
10# util-linux for libblkid 10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3" 11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3"
12RDEPENDS_${PN} = "rpcbind" 12RDEPENDS_${PN}-client = "rpcbind"
13RDEPENDS_${PN} = "${PN}-client"
13RRECOMMENDS_${PN} = "kernel-module-nfsd" 14RRECOMMENDS_${PN} = "kernel-module-nfsd"
14 15
16inherit useradd
17
18USERADD_PACKAGES = "${PN}-client"
19USERADD_PARAM_${PN}-client = "-d /var/lib/nfs -r -s /bin/false rpcuser"
20
15SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.bz2 \ 21SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.bz2 \
16 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \ 22 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
17 file://nfs-utils-1.0.6-uclibc.patch \ 23 file://nfs-utils-1.0.6-uclibc.patch \
18 file://nfs-utils-1.2.3-sm-notify-res_init.patch \ 24 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
19 file://nfsserver \ 25 file://nfsserver \
26 file://nfscommon \
20 file://nfs-utils.conf \ 27 file://nfs-utils.conf \
21 file://nfs-server.service \ 28 file://nfs-server.service \
22 file://nfs-mountd.service \ 29 file://nfs-mountd.service \
@@ -30,15 +37,16 @@ PARALLEL_MAKE = ""
30# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will 37# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
31# pull in the remainder of the dependencies. 38# pull in the remainder of the dependencies.
32 39
40INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
33INITSCRIPT_NAME = "nfsserver" 41INITSCRIPT_NAME = "nfsserver"
34# The server has no dependencies at the user run levels, so just put
35# it in at the default levels. It must be terminated before the network
36# in the shutdown levels, but that works fine.
37INITSCRIPT_PARAMS = "defaults" 42INITSCRIPT_PARAMS = "defaults"
43INITSCRIPT_NAME_${PN}-client = "nfscommon"
44INITSCRIPT_PARAMS_${PN}-client = "start 44 S ."
38 45
39inherit autotools update-rc.d systemd 46inherit autotools update-rc.d systemd
40 47
41SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service nfs-statd.service" 48SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
49SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
42SYSTEMD_AUTO_ENABLE = "disable" 50SYSTEMD_AUTO_ENABLE = "disable"
43 51
44# --enable-uuid is need for cross-compiling 52# --enable-uuid is need for cross-compiling
@@ -60,7 +68,13 @@ PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
60INHIBIT_AUTO_STAGE = "1" 68INHIBIT_AUTO_STAGE = "1"
61 69
62PACKAGES =+ "${PN}-client ${PN}-stats" 70PACKAGES =+ "${PN}-client ${PN}-stats"
63FILES_${PN}-client = "${base_sbindir}/*mount.nfs*" 71FILES_${PN}-client = "${base_sbindir}/*mount.nfs* ${sbindir}/*statd \
72 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
73 ${sbindir}/showmount ${sbindir}/nfsstat \
74 ${localstatedir}/lib/nfs \
75 ${sysconfdir}/nfs-utils.conf \
76 ${sysconfdir}/init.d/nfscommon \
77 ${systemd_unitdir}/system/nfs-statd.service"
64FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat" 78FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
65RDEPENDS_${PN}-stats = "python" 79RDEPENDS_${PN}-stats = "python"
66 80
@@ -74,6 +88,7 @@ do_install_append () {
74 install -d ${D}${sysconfdir}/init.d 88 install -d ${D}${sysconfdir}/init.d
75 install -d ${D}${localstatedir}/lib/nfs/statd 89 install -d ${D}${localstatedir}/lib/nfs/statd
76 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver 90 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
91 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
77 92
78 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir} 93 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
79 install -d ${D}${systemd_unitdir}/system 94 install -d ${D}${systemd_unitdir}/system