summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
diff options
context:
space:
mode:
authorAndrei Dinu <andrei.adrianx.dinu@intel.com>2013-05-15 12:32:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 00:18:45 +0100
commitb86fdc09c87e4353ef163d82a4a0b38583fdcc91 (patch)
treeed8b061ed24fc7193a78a61937150921a8a680a9 /meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
parent503c669ca7af397cba0286908f2db2b5d533c0c3 (diff)
downloadpoky-b86fdc09c87e4353ef163d82a4a0b38583fdcc91.tar.gz
nfs-utils : upgrade to 1.2.8
upgrade from 1.2.7 -> 1.2.8 Removed patches that are already in the upstream. Added a make clean routine needed because the package comes with precompiled 64-bit objects that break the build. (From OE-Core rev: f505e913eae5e91d494234ee38a38ac961583b12) Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
new file mode 100644
index 0000000000..2f3509410a
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
@@ -0,0 +1,72 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers sqlite3"
12RDEPENDS_${PN} = "rpcbind"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.bz2 \
16 file://nfs-utils-1.0.6-uclibc.patch \
17 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
18 file://nfsserver"
19
20SRC_URI[md5sum] = "6e7d97de51e428a0b8698c16ca23db77"
21SRC_URI[sha256sum] = "1cc8f02a633eddbf0a1d93421f331479c4cdab4c5ab33b8bf8c7c369f9156ac6"
22
23PARALLEL_MAKE = ""
24
25# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
26# pull in the remainder of the dependencies.
27
28INITSCRIPT_NAME = "nfsserver"
29# The server has no dependencies at the user run levels, so just put
30# it in at the default levels. It must be terminated before the network
31# in the shutdown levels, but that works fine.
32INITSCRIPT_PARAMS = "defaults"
33
34inherit autotools update-rc.d
35
36# --enable-uuid is need for cross-compiling
37EXTRA_OECONF = "--with-statduser=nobody \
38 --enable-mountconfig \
39 --enable-libmount-mount \
40 --disable-nfsv41 \
41 --enable-uuid \
42 --disable-gss \
43 --disable-tirpc \
44 --disable-nfsdcltrack \
45 --with-statdpath=/var/lib/nfs/statd \
46 "
47
48INHIBIT_AUTO_STAGE = "1"
49
50PACKAGES =+ "${PN}-client ${PN}-stats"
51FILES_${PN}-client = "${base_sbindir}/*mount.nfs*"
52FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
53RDEPENDS_${PN}-stats = "python"
54
55# Make clean needed because the package comes with
56# precompiled 64-bit objects that break the build
57do_compile_prepend() {
58 make clean
59}
60
61do_install_append () {
62 install -d ${D}${sysconfdir}/init.d
63 install -d ${D}${localstatedir}/lib/nfs/statd
64 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
65 # kernel code as of 3.8 hard-codes this path as a default
66 install -d ${D}/var/lib/nfs/v4recovery
67
68 # the following are built by CC_FOR_BUILD
69 rm -f ${D}${sbindir}/rpcdebug
70 rm -f ${D}${sbindir}/rpcgen
71 rm -f ${D}${sbindir}/locktest
72}