summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-21 21:04:26 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-25 12:42:43 +0000
commit8adcafc239ccb3fa9fc968140b43da90d735ce21 (patch)
treedab876fab92305921a4b7e3c0f93f9360f4a6e94 /meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb
parent3991c5520e584635d3034f27ce817c453b36fb2d (diff)
downloadpoky-8adcafc239ccb3fa9fc968140b43da90d735ce21.tar.gz
nfs-utils: Upgrade 1.2.3 -> 1.2.8-rc3
Disable nfsv4l since it needs LVM2 which is not available in OE-Core Disable nfsdcltrack since its configure time check for sqlite3 is not cross compiling safe It can support ipv6 but thats disabled since we disable libtirpc which is needed for ipv6 support in nfs-utils Patches imported from fedora to take us to 1.2.8-rc3 (From OE-Core rev: 658bfe4690005d0a68dc4e3ca2bc741ff4c89f28) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb
new file mode 100644
index 0000000000..5bad6f17ad
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.7.bb
@@ -0,0 +1,65 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers sqlite3"
12RDEPENDS_${PN} = "rpcbind"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.bz2 \
16 file://nfs-utils.1.2.8.rc3.patch \
17 file://nfs-utils-1.0.6-uclibc.patch \
18 file://nfs-utils-1.2.3-uclibc-libio.h.patch \
19 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
20 file://nfsserver"
21
22SRC_URI[md5sum] = "3b5ca797197765dc0c3a4122720c7716"
23SRC_URI[sha256sum] = "7ef8e0a8b22cd7ff33f3afd28e770d45643fae303468a180640c2967833fe75e"
24
25PARALLEL_MAKE = ""
26
27# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
28# pull in the remainder of the dependencies.
29
30INITSCRIPT_NAME = "nfsserver"
31# The server has no dependencies at the user run levels, so just put
32# it in at the default levels. It must be terminated before the network
33# in the shutdown levels, but that works fine.
34INITSCRIPT_PARAMS = "defaults"
35
36inherit autotools update-rc.d
37
38# --enable-uuid is need for cross-compiling
39EXTRA_OECONF = "--with-statduser=nobody \
40 --enable-mountconfig \
41 --enable-libmount-mount \
42 --disable-nfsv41 \
43 --enable-uuid \
44 --disable-gss \
45 --disable-tirpc \
46 --disable-nfsdcltrack \
47 --with-statdpath=/var/lib/nfs/statd \
48 "
49
50INHIBIT_AUTO_STAGE = "1"
51
52PACKAGES =+ "${PN}-client ${PN}-stats"
53FILES_${PN}-client = "${base_sbindir}/*mount.nfs*"
54FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
55RDEPENDS_${PN}-stats = "python"
56
57do_install_append () {
58 install -d ${D}${sysconfdir}/init.d
59 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
60
61 # the following are built by CC_FOR_BUILD
62 rm -f ${D}${sbindir}/rpcdebug
63 rm -f ${D}${sbindir}/rpcgen
64 rm -f ${D}${sbindir}/locktest
65}