diff options
author | Olivier Guiter <olivier.guiter@linux.intel.com> | 2013-03-04 19:06:13 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-03-07 11:14:38 +0000 |
commit | d5cfb00f080b68c09660d222437518813816da82 (patch) | |
tree | c73e710a7e96cc444cd720780da1a4323312929a /meta/recipes-connectivity/neard/neard_0.9.bb | |
parent | 45452bc0c3575e44fe2167a07ee9e4e829fd4b5b (diff) | |
download | poky-d5cfb00f080b68c09660d222437518813816da82.tar.gz |
Near Field communication recipe for neard 0.9
The Linux NFC project aims to provide a full NFC support for Linux.
It is based on the neard NFC user space stack running on top of the
Linux kernel NFC subsystem.
The code generated using this recipe was tested on a ARM11 device, with
a kernel 3.6, using, for the NFC hardware, a USB dongle with the PN533
chipset (SCL3711)
(From OE-Core rev: b2a74ae70725be7efc0226901fd560d3b3b48607)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/neard/neard_0.9.bb')
-rw-r--r-- | meta/recipes-connectivity/neard/neard_0.9.bb | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/neard/neard_0.9.bb b/meta/recipes-connectivity/neard/neard_0.9.bb new file mode 100644 index 0000000000..61ea58cc14 --- /dev/null +++ b/meta/recipes-connectivity/neard/neard_0.9.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | SUMMARY = "Linux NFC daemon" | ||
2 | DESCRIPTION = "A daemon for the Linux Near Field Communication stack" | ||
3 | HOMEPAGE = "http://01.org/linux-nfc" | ||
4 | |||
5 | LICENSE = "GPLv2" | ||
6 | |||
7 | DEPENDS = "dbus glib-2.0 libnl" | ||
8 | |||
9 | inherit autotools pkgconfig update-rc.d | ||
10 | |||
11 | INITSCRIPT_NAME = "neard" | ||
12 | INITSCRIPT_PARAMS = "defaults 64" | ||
13 | |||
14 | # This would copy neard start-stop shell and test scripts | ||
15 | do_install_append() { | ||
16 | install -d ${D}${sysconfdir}/init.d/ | ||
17 | install -m 0755 ${WORKDIR}/neard ${D}${sysconfdir}/init.d/neard | ||
18 | |||
19 | install -d ${D}${libdir}/neard | ||
20 | install -m 0755 ${S}/test/* ${D}${libdir}/neard/ | ||
21 | install -m 0755 ${S}/tools/nfctool/nfctool ${D}${libdir}/neard/ | ||
22 | } | ||
23 | |||
24 | RDEPENDS_${PN} = "dbus python python-dbus python-pygobject" | ||
25 | |||
26 | # Bluez & Wifi are not mandatory except for handover " | ||
27 | RRECOMMENDS_${PN} = "\ | ||
28 | ${@base_contains('DISTRO_FEATURES', 'bluetooth', 'bluez4', '', d)} \ | ||
29 | ${@base_contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \ | ||
30 | " | ||
31 | |||
32 | #Additional | ||
33 | PACKAGES =+ "${PN}-tests" | ||
34 | |||
35 | FILES_${PN}-tests = "${libdir}/neard/*-test" | ||
36 | RDEPENDS_${PN}-tests = "python python-dbus python-pygobject" | ||
37 | |||
38 | FILES_${PN}-dbg += "${bindir}/neard/*/.debug" | ||
39 | |||
40 | ##============================= | ||
41 | # This is valid for 0.9+ | ||
42 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ | ||
43 | file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \ | ||
44 | " | ||
45 | S = "${WORKDIR}/git" | ||
46 | SRCREV = "7abdb13d106d496e1115fab49e6448a249dfb3c8" | ||
47 | PV = "0.9-git${SRCPV}" | ||
48 | PR = "r1" | ||
49 | |||
50 | SRC_URI = "git://git.kernel.org/pub/scm/network/nfc/neard.git;protocol=git \ | ||
51 | file://neard \ | ||
52 | " | ||
53 | |||
54 | EXTRA_OECONF += "--enable-tools \ | ||
55 | " | ||
56 | |||
57 | |||