summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb
diff options
context:
space:
mode:
authorMei Lei <lei.mei@intel.com>2011-07-04 17:12:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-07 11:14:00 +0100
commit74daaf19cb124a24a45c04a6cac626b0037be75a (patch)
tree54dd8c22c891f4bbffec2d529fdcfcc372aed1ab /meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb
parentd8f13889e6b4926645764344a014d5b5d59271b0 (diff)
downloadpoky-74daaf19cb124a24a45c04a6cac626b0037be75a.tar.gz
gupnp: Upgrade from 0.16.0 to 0.16.1
Add introspection.patch from gssdp due to more strict compiler checks in new version (From OE-Core rev: 421ca72552b47923cb01e49288a4fa28b70c019a) Signed-off-by: Mei Lei <lei.mei@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb')
-rw-r--r--meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb b/meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb
new file mode 100644
index 0000000000..fd2eb3886c
--- /dev/null
+++ b/meta/recipes-connectivity/gupnp/gupnp_0.16.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "UPnP framework"
2DESCRIPTION = "GUPnP is an elegant, object-oriented open source framework for creating UPnP devices and control points, written in C using GObject and libsoup. The GUPnP API is intended to be easy to use, efficient and flexible. It provides the same set of features as libupnp, but shields the developer from most of UPnP's internals."
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
5 file://libgupnp/gupnp.h;beginline=1;endline=20;md5=28c49b17d623afc3335efc2e511879e1"
6DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2 gnome-icon-theme"
7
8SRC_URI = "http://gupnp.org/sites/all/files/sources/${BPN}-${PV}.tar.gz \
9 file://introspection.patch"
10
11SRC_URI[md5sum] = "021bb237741532af4bca50157ff326e4"
12SRC_URI[sha256sum] = "f01a1f4fd36ce161a3df29fa83e1a0a2fb40d3c9f30f6b403e7791688ad24cfe"
13
14PR = "r0"
15
16EXTRA_OECONF = "--disable-introspection"
17
18inherit autotools pkgconfig
19
20FILES_${PN} = "${libdir}/*.so.*"
21FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
22
23SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
24
25gupnp_sysroot_preprocess () {
26 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
27 install -m 755 ${D}${bindir}/gupnp-binding-tool ${SYSROOT_DESTDIR}${bindir_crossscripts}/
28}
29