summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-04-13 16:25:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:49:24 +0100
commit3abaef517141b82adae3b2c106c77b09618ad433 (patch)
treec850b846d91d6e90bb9137491e86ce3725825d5f /meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
parent8d93f7afe59da4a86ba8764b8743fd0525798973 (diff)
downloadpoky-3abaef517141b82adae3b2c106c77b09618ad433.tar.gz
gupnp: upgrade to version 0.16.0
Remove introspection.patch since it is already in upsteram. (From OE-Core rev: d8a6152dee4a1abaf0d5cf62735bdaf68d04eeb4) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb')
-rw-r--r--meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb b/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
new file mode 100644
index 0000000000..07b6b90e7c
--- /dev/null
+++ b/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "UPnP framework"
2DESCRIPTION = "GUPnP is an elegant, object-oriented open source framework for creating UPnP devices and control points, written in C using GObject and libsoup. The GUPnP API is intended to be easy to use, efficient and flexible. It provides the same set of features as libupnp, but shields the developer from most of UPnP's internals."
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
5 file://libgupnp/gupnp.h;beginline=1;endline=20;md5=28c49b17d623afc3335efc2e511879e1"
6DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2 gnome-icon-theme"
7
8SRC_URI = "http://gupnp.org/sites/all/files/sources/${BPN}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "61b240c1a9fdf8ca82c5c3adde0d6757"
11SRC_URI[sha256sum] = "1b77201866b7632fb68bc2a3bdea22ef8ead34ba850b3ee367797432cfc0f04a"
12
13PR = "r0"
14
15EXTRA_OECONF = "--disable-introspection"
16
17inherit autotools pkgconfig
18
19FILES_${PN} = "${libdir}/*.so.*"
20FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
21
22SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
23
24gupnp_sysroot_preprocess () {
25 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
26 install -m 755 ${D}${bindir}/gupnp-binding-tool ${SYSROOT_DESTDIR}${bindir_crossscripts}/
27}
28