summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-12-07 16:56:37 +0800
committerSaul Wold <sgw@linux.intel.com>2010-12-08 15:02:09 -0800
commitf84c6d2cca4bed35d3bb5d9b2d8d2c5de82e8c4e (patch)
tree17465de9c8940000c5c8b8cc054d4b5f0f2503da /meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb
parent2628ea70661b6a36ee351018967bbe3b7e5d16c1 (diff)
downloadpoky-f84c6d2cca4bed35d3bb5d9b2d8d2c5de82e8c4e.tar.gz
gupnp: upgrade to version 0.14.0
Derive introspection.m4 from gobject-introspection package to solve the autoreconf issue. Add option "--disable-introspection" since gobject-introspection breaks cross compile. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb')
-rw-r--r--meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb b/meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb
new file mode 100644
index 0000000000..2fa2f7ba18
--- /dev/null
+++ b/meta/recipes-connectivity/gupnp/gupnp_0.14.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "UPnP framework"
2DESCRIPTION = "GUPnP is an elegant, object-oriented open source framework for creating UPnP devices and control points, written in C using GObject and libsoup. The GUPnP API is intended to be easy to use, efficient and flexible. It provides the same set of features as libupnp, but shields the developer from most of UPnP's internals."
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
5 file://libgupnp/gupnp.h;beginline=1;endline=20;md5=28c49b17d623afc3335efc2e511879e1"
6DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2 gnome-icon-theme"
7
8SRC_URI = "http://gupnp.org/sites/all/files/sources/${PN}-${PV}.tar.gz \
9 file://introspection.patch"
10PR = "r0"
11
12EXTRA_OECONF = "--disable-introspection"
13
14inherit autotools pkgconfig
15
16FILES_${PN} = "${libdir}/*.so.*"
17FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
18
19SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
20
21gupnp_sysroot_preprocess () {
22 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
23 install -m 755 ${D}${bindir}/gupnp-binding-tool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
24}
25
26SRC_URI[md5sum] = "8598922256faa5adb28657d0c10a3e3e"
27SRC_URI[sha256sum] = "6ac13efe46c6f1e5d05e48e1041bf37dfa702839ce5fbb01e0f314f3904b6a16"