summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-09-22 08:42:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-22 22:23:36 +0100
commit60d0c57ed6e46826b4346b278cad4f819f75e674 (patch)
treed9659c8947a2561ca2c705c14de8a17bc73c6b41 /meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb
parent0b9bd3c99450bba79431d69e8bfdd4fe5168d55c (diff)
downloadpoky-60d0c57ed6e46826b4346b278cad4f819f75e674.tar.gz
bluez4: split gstreamer plugin into a seperate recipe
This eliminates a good chunk of buildtime when building console-only image. The bluez4 and this recipe share a .inc file since the source is the same. (From OE-Core rev: 5eaed4bba35e8188855acb93344adf48201748a2) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb')
-rw-r--r--meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb b/meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb
new file mode 100644
index 0000000000..a137b12e21
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/gst-plugin-bluetooth_4.96.bb
@@ -0,0 +1,28 @@
1require bluez4.inc
2require recipes-multimedia/gstreamer/gst-plugins-package.inc
3
4DEPENDS = "bluez4 gst-plugins-base"
5
6EXTRA_OECONF = "\
7 --enable-gstreamer \
8"
9
10# clean unwanted files
11do_install_append() {
12 rm -rf ${D}${bindir}
13 rm -rf ${D}${sbindir}
14 rm -f ${D}${libdir}/lib*
15 rm -rf ${D}${sysconfdir}
16 rm -rf ${D}${base_libdir}
17}
18
19FILES_${PN} = "${libdir}/gstreamer-0.10/lib*.so"
20FILES_${PN}-dev += "\
21 ${libdir}/gstreamer-0.10/*.la \
22"
23
24FILES_${PN}-dbg += "\
25 ${libdir}/*/.debug \
26"
27
28