summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/bluez4_4.98.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2012-01-22 15:08:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-24 11:54:23 +0000
commite96ec29709716ee6a01f61848d9ff2a825fcbb52 (patch)
tree93bee7efb1f04369c7c2dc88eef6fa13f2a29fd1 /meta/recipes-connectivity/bluez/bluez4_4.98.bb
parenta3c689963924d3637414b062038ea9c9adffb6f2 (diff)
downloadpoky-e96ec29709716ee6a01f61848d9ff2a825fcbb52.tar.gz
bluez4: upgrade to 4.98
(From OE-Core rev: 8d3188a4a69214f23d8b7f8d972bdd35f574196b) Signed-off-by: Shane Wang <shane.wang@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.98.bb')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.98.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.98.bb b/meta/recipes-connectivity/bluez/bluez4_4.98.bb
new file mode 100644
index 0000000000..62de1feb48
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4_4.98.bb
@@ -0,0 +1,33 @@
1require bluez4.inc
2
3PR = "r0"
4
5SRC_URI += "file://bluetooth.conf"
6
7SRC_URI[md5sum] = "362864b716950baa04797de735fc237b"
8SRC_URI[sha256sum] = "9a5b655bada7c7a1921cb3bac83b8a32bbe49893e4c7a1377cdc1b0d35f7d233"
9
10do_install_append() {
11 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
12 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
13 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
14 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
15 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
16}
17
18RDEPENDS_${PN}-dev = "bluez-hcidump"
19
20PACKAGES =+ "libasound-module-bluez"
21
22FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
23FILES_${PN} += "${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${base_libdir}/systemd/"
24FILES_${PN}-dev += "\
25 ${libdir}/bluetooth/plugins/*.la \
26 ${libdir}/alsa-lib/*.la \
27"
28
29FILES_${PN}-dbg += "\
30 ${libdir}/bluetooth/plugins/.debug \
31 ${libdir}/*/.debug \
32 ${base_libdir}/udev/.debug \
33 "