summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/bluez4_4.101.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2012-09-17 12:30:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-28 16:53:15 +0100
commit3c3614c562bb64c5428f18188809a56ab2b5409c (patch)
treef9659eca415a4b4fd8e2ea4db5fe652dc69df3c6 /meta/recipes-connectivity/bluez/bluez4_4.101.bb
parent1c71304f81f58ab3b209ccafac1cb3da665d1c76 (diff)
downloadpoky-3c3614c562bb64c5428f18188809a56ab2b5409c.tar.gz
bluez4: update to ver. 4.101
(From OE-Core rev: 6e6407e9a8c59cb51685c4b767b62eacb8dbf852) Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.101.bb')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.101.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.101.bb b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
new file mode 100644
index 0000000000..a2ba66f05b
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
@@ -0,0 +1,35 @@
1require bluez4.inc
2
3PR = "r0"
4
5SRC_URI += "file://bluetooth.conf \
6 file://sbc_mmx.patch"
7
8SRC_URI[md5sum] = "fb42cb7038c380eb0e2fa208987c96ad"
9SRC_URI[sha256sum] = "59738410ade9f0e61a13c0f77d9aaffaafe49ba9418107e4ad75fe52846f7487"
10
11do_install_append() {
12 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
13 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
14 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
15 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
16 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
17}
18
19RDEPENDS_${PN}-dev = "bluez-hcidump"
20
21ALLOW_EMPTY_libasound-module-bluez = "1"
22PACKAGES =+ "libasound-module-bluez"
23
24FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
25FILES_${PN} += "${libdir}/bluetooth/plugins ${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${systemd_unitdir}/"
26FILES_${PN}-dev += "\
27 ${libdir}/bluetooth/plugins/*.la \
28 ${libdir}/alsa-lib/*.la \
29"
30
31FILES_${PN}-dbg += "\
32 ${libdir}/bluetooth/plugins/.debug \
33 ${libdir}/*/.debug \
34 ${base_libdir}/udev/.debug \
35 "