summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/avahi
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2011-09-07 20:23:48 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-07 22:44:29 (GMT)
commit52835dd30110d51a839872f198eef3b12e369850 (patch)
treefbeaf87b51dc00cfae196eeb605b81f720b2403d /meta/recipes-connectivity/avahi
parent00b47701f4818091bfd694a32dcbfb1b12fb2427 (diff)
downloadpoky-52835dd30110d51a839872f198eef3b12e369850.tar.gz
avahi: only use gtk if DISTRO_FEATURES includes x11
Otherwise avahi isn't buildable for an x11-less DISTRO. (From OE-Core rev: fa8dad209247b780590bc8476b5b16e6608d7907) Signed-off-by: Phil Blundell <philb@gnu.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/avahi')
-rw-r--r--meta/recipes-connectivity/avahi/avahi.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/avahi/avahi.inc b/meta/recipes-connectivity/avahi/avahi.inc
index dc7a5ae..24ea458 100644
--- a/meta/recipes-connectivity/avahi/avahi.inc
+++ b/meta/recipes-connectivity/avahi/avahi.inc
@@ -14,7 +14,8 @@ SECTION = "network"
14# python scripts are under GPLv2+ 14# python scripts are under GPLv2+
15LICENSE = "GPLv2+ & LGPLv2.1+" 15LICENSE = "GPLv2+ & LGPLv2.1+"
16 16
17DEPENDS = "expat libcap libdaemon dbus glib-2.0 gtk+ libglade" 17X11DEPENDS = "gtk+ libglade"
18DEPENDS = "expat libcap libdaemon dbus glib-2.0 ${@base_contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
18 19
19SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \ 20SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
20 file://00avahi-autoipd \ 21 file://00avahi-autoipd \
@@ -30,6 +31,7 @@ EXTRA_OECONF = "--with-distro=debian \
30 --disable-mono \ 31 --disable-mono \
31 --disable-monodoc \ 32 --disable-monodoc \
32 --disable-gtk3 \ 33 --disable-gtk3 \
34 ${@base_contains('DISTRO_FEATURES', 'x11', '--enable-gtk', '--disable-gtk', d)} \
33 --disable-qt3 \ 35 --disable-qt3 \
34 --disable-qt4 \ 36 --disable-qt4 \
35 --disable-python \ 37 --disable-python \