diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2014-10-09 08:37:41 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-10-10 16:44:33 +0100 |
commit | afeb590d935baba22d064387c10b7735fae788d2 (patch) | |
tree | c5097b8a1f2d989f0d79c9d89c60b13cc595c8d2 /meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb | |
parent | 08a86f89fbb770acf8c0340ce11199caf52d8eb6 (diff) | |
download | poky-afeb590d935baba22d064387c10b7735fae788d2.tar.gz |
avahi-ui: fix for building systemd with multilib
Fixed:
MACHINE = "qemux86-64"
VIRTUAL-RUNTIME_init_manager = " systemd "
DISTRO_FEATURES_append = " systemd"
DISTRO_FEATURES_BACKFILL_CONSIDERED += " sysvinit "
require conf/multilib.conf
MULTILIBS = "multilib:lib32"
DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
$ bitbake avahi avahi-ui
ERROR: QA Issue: avahi-ui: Files/directories were installed but not shipped
/lib
/lib/systemd
/lib/systemd/system
/lib/systemd/system/avahi-daemon.socket
/lib/systemd/system/avahi-dnsconfd.service
/lib/systemd/system/avahi-daemon.service [installed-vs-shipped]
ERROR: The recipe avahi-ui is trying to install files into a sharedarea when those files already exist. Those files and their manifestlocation are:
/path/to/sysroots/qemux86-64/lib/systemd/system/avahi-daemon.socket
Matched in manifest-qemux86-64-avahi.populate_sysroot
/path/to/sysroots/qemux86-64/lib/systemd/system/avahi-dnsconfd.service
Matched in manifest-qemux86-64-avahi.populate_sysroot
/path/to/sysroots/qemux86-64/lib/systemd/system/avahi-daemon.service
Matched in manifest-qemux86-64-avahi.populate_sysroot
Please verify which recipe should provide theabove files.
And remove the duplicated line:
rm ${D}${base_libdir} -rf
(From OE-Core rev: 1e6ec39d4996d2812b01c4452c579e476e70e85d)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb')
-rw-r--r-- | meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb b/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb index 070530ec3f..eea4d70fab 100644 --- a/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb +++ b/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb | |||
@@ -45,7 +45,11 @@ RDEPENDS_python-avahi = "python-core python-dbus" | |||
45 | do_install_append () { | 45 | do_install_append () { |
46 | rm ${D}${sysconfdir} -rf | 46 | rm ${D}${sysconfdir} -rf |
47 | rm ${D}${base_libdir} -rf | 47 | rm ${D}${base_libdir} -rf |
48 | rm ${D}${base_libdir} -rf | 48 | rm ${D}${systemd_unitdir} -rf |
49 | # The ${systemd_unitdir} is /lib/systemd, so we need rmdir /lib, | ||
50 | # but not ${base_libdir} here. And the /lib may not exist | ||
51 | # whithout systemd. | ||
52 | [ ! -d ${D}/lib ] || rmdir ${D}/lib --ignore-fail-on-non-empty | ||
49 | rm ${D}${bindir}/avahi-b* | 53 | rm ${D}${bindir}/avahi-b* |
50 | rm ${D}${bindir}/avahi-p* | 54 | rm ${D}${bindir}/avahi-p* |
51 | rm ${D}${bindir}/avahi-r* | 55 | rm ${D}${bindir}/avahi-r* |