summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d/v86d_0.1.10.bb
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2018-10-31 16:55:47 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-07 23:08:55 +0000
commita7bf511703d67af956e8d8152a53ec1a58b31ee1 (patch)
tree409e9169db87320564482716f0c64c1f538470f2 /meta/recipes-bsp/v86d/v86d_0.1.10.bb
parent8929ffd67c6de431c2561f63c5427df6c354d30f (diff)
downloadpoky-a7bf511703d67af956e8d8152a53ec1a58b31ee1.tar.gz
v86d: Make cross compilation working on more architectures
Since commit 709c603dec19 ("v86d: Accept aarch64 as build host") we support cross compilation on aarch64 host in addition to x86 host. However building on hosts different than two above will fail. Make cross compilation support more generic by checking for TARGET_ARCH in v86d configure script with fallback to `uname -m` when not present in environment and pass TARGET_ARCH explicitly in do_configure(). Cross build for x86 tested on IBM Power 8 machine with RHEL7. Should work on aarch64 and rest too. (From OE-Core rev: 69f7579eb36c00b557225377e1a3cc61b103be23) Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/v86d/v86d_0.1.10.bb')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
index f97b80d08f..84e27d2007 100644
--- a/meta/recipes-bsp/v86d/v86d_0.1.10.bb
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -12,7 +12,7 @@ PR = "r2"
12SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \ 12SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \
13 file://Update-x86emu-from-X.org.patch \ 13 file://Update-x86emu-from-X.org.patch \
14 file://ar-from-env.patch \ 14 file://ar-from-env.patch \
15 file://aarch64-host.patch \ 15 file://Support-for-cross-compilation.patch \
16" 16"
17 17
18SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2" 18SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2"
@@ -22,7 +22,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
22COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 22COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
23 23
24do_configure () { 24do_configure () {
25 ./configure --with-x86emu 25 TARGET_ARCH="${TARGET_ARCH}" ./configure --with-x86emu
26} 26}
27 27
28do_compile () { 28do_compile () {