summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
diff options
context:
space:
mode:
authorIlya Yanok <yanok@emcraft.com>2011-06-28 16:54:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 17:13:19 +0100
commita4f3e006e1f2fd93f156012af2a05adccf41d065 (patch)
tree020f4d7226ebd9040f00db6c23534d9a4289b525 /meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
parenteb1c557d02d5781305d2bd7cc7c28b3c3e21e593 (diff)
downloadpoky-a4f3e006e1f2fd93f156012af2a05adccf41d065.tar.gz
u-boot-mkimage: bump version to 2011.03
This patch changes u-boot-mkimage version to 2011.03. Unfortunately U-Boot 2011.03 release has some problems building tools from unconfigured tree, so this patch aslo includes the backported fixes. (From OE-Core rev: 8a5c20417d4d6bee6dd0bcdbeb8d4f9e0696a216) Signed-off-by: Ilya Yanok <yanok@emcraft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb')
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb25
1 files changed, 0 insertions, 25 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
deleted file mode 100644
index eab286c272..0000000000
--- a/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPL"
3SECTION = "bootloader"
4
5SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
6 file://fix-arm920t-eabi.patch;patch=1"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
9
10S = "${WORKDIR}/u-boot-${PV}"
11
12inherit native
13
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
15
16do_compile () {
17 oe_runmake smdk2410_config
18 oe_runmake tools
19}
20
21do_install () {
22 install -d ${D}${bindir}/
23 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
24 ln -sf uboot-mkimage ${D}${bindir}/mkimage
25}