summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-03-25 09:01:57 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-29 12:05:31 +0100
commita7f74a4a08827c59565a7805e0189e408397b891 (patch)
tree11b30123341646a75f6f4734b3c3fd8079f9b9de /meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
parent117a6dac73b7642f56e9e51a890748679d6dbab4 (diff)
downloadpoky-a7f74a4a08827c59565a7805e0189e408397b891.tar.gz
u-boot-tools: Split out inc file
Spilts out the inc file for u-boot-tools so that BSPs can include it for their forked version of the tools, just like u-boot.inc. As an example, this recipe [1] builds mkimage u-boot as part of the u-boot recipe itself. This is incorrect because u-boot is a target recipe, which means that the uninative loader transformations do not get applied when the recipe is restored from sstate, breaking the mkimage command breaks. The correct solution is to have a u-boot-tools-imx recipe that pulls in their custom u-boot source; this inc file makes that much easier to maintain. [1]: https://github.com/Freescale/meta-freescale/blob/aa27fc62095cfd6c147c8f6865296ddc29bf0fa6/recipes-bsp/u-boot/u-boot-imx_2019.04.bb (From OE-Core rev: 2f3bd198d9b1e85f17f7a587b1690ab196ab0300) Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb67
1 files changed, 1 insertions, 66 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb b/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
index 414ee333ff..7eaf721ca8 100644
--- a/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
@@ -1,67 +1,2 @@
1require u-boot-common.inc 1require u-boot-common.inc
2 2require u-boot-tools.inc
3SUMMARY = "U-Boot bootloader tools"
4DEPENDS += "openssl"
5
6PROVIDES = "${MLPREFIX}u-boot-mkimage ${MLPREFIX}u-boot-mkenvimage"
7PROVIDES_class-native = "u-boot-mkimage-native u-boot-mkenvimage-native"
8
9PACKAGES += "${PN}-mkimage ${PN}-mkenvimage"
10
11# Required for backward compatibility with "u-boot-mkimage-xxx.bb"
12RPROVIDES_${PN}-mkimage = "u-boot-mkimage"
13RREPLACES_${PN}-mkimage = "u-boot-mkimage"
14RCONFLICTS_${PN}-mkimage = "u-boot-mkimage"
15
16EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
17EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
18EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
19
20SED_CONFIG_EFI = '-e "s/CONFIG_EFI_LOADER=.*/# CONFIG_EFI_LOADER is not set/"'
21SED_CONFIG_EFI_x86 = ''
22SED_CONFIG_EFI_x86-64 = ''
23SED_CONFIG_EFI_arm = ''
24SED_CONFIG_EFI_armeb = ''
25SED_CONFIG_EFI_aarch64 = ''
26
27do_compile () {
28 oe_runmake -C ${S} sandbox_defconfig O=${B}
29
30 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
31 # generating it requires bin2header tool, which for target build
32 # is built with target tools and thus cannot be executed on host.
33 sed -i -e "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" ${SED_CONFIG_EFI} ${B}/.config
34
35 oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B}
36}
37
38do_install () {
39 install -d ${D}${bindir}
40
41 # mkimage
42 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
43 ln -sf uboot-mkimage ${D}${bindir}/mkimage
44
45 # mkenvimage
46 install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
47 ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
48
49 # dumpimage
50 install -m 0755 tools/dumpimage ${D}${bindir}/uboot-dumpimage
51 ln -sf uboot-dumpimage ${D}${bindir}/dumpimage
52
53 # fit_check_sign
54 install -m 0755 tools/fit_check_sign ${D}${bindir}/uboot-fit_check_sign
55 ln -sf uboot-fit_check_sign ${D}${bindir}/fit_check_sign
56}
57
58ALLOW_EMPTY_${PN} = "1"
59FILES_${PN} = ""
60FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage ${bindir}/uboot-dumpimage ${bindir}/dumpimage ${bindir}/uboot-fit_check_sign ${bindir}/fit_check_sign"
61FILES_${PN}-mkenvimage = "${bindir}/uboot-mkenvimage ${bindir}/mkenvimage"
62
63RDEPENDS_${PN}-mkimage += "dtc"
64RDEPENDS_${PN} += "${PN}-mkimage ${PN}-mkenvimage"
65RDEPENDS_${PN}_class-native = ""
66
67BBCLASSEXTEND = "native nativesdk"