summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-04-01 09:27:36 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-17 08:29:02 +0100
commit5a3dd29f607aa401b9a3f7dcc837c24840718ed5 (patch)
tree4e9a89f9fe3ba355976d38bd920cf263e9e9eae0 /meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb
parent5531ffc5668c2f24b9018a7b7174b5c77315a1cf (diff)
downloadpoky-5a3dd29f607aa401b9a3f7dcc837c24840718ed5.tar.gz
u-boot-tools: Split out inc file
Spilts out the inc file for u-boot-tools so that BSPs can include it for their forked version of the tools, just like u-boot.inc. As an example, this recipe [1] builds mkimage u-boot as part of the u-boot recipe itself. This is incorrect because u-boot is a target recipe, which means that the uninative loader transformations do not get applied when the recipe is restored from sstate, breaking the mkimage command breaks. The correct solution is to have a u-boot-tools-imx recipe that pulls in their custom u-boot source; this inc file makes that much easier to maintain. [1]: https://github.com/Freescale/meta-freescale/blob/aa27fc62095cfd6c147c8f6865296ddc29bf0fa6/recipes-bsp/u-boot/u-boot-imx_2019.04.bb (From OE-Core rev: 2e15642ada8b5403ac933072a581b9af9a359122) Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 2f3bd198d9b1e85f17f7a587b1690ab196ab0300) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb67
1 files changed, 1 insertions, 66 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb b/meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb
index bede984ef7..7eaf721ca8 100644
--- a/meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-tools_2019.07.bb
@@ -1,67 +1,2 @@
1require u-boot-common.inc 1require u-boot-common.inc
2 2require u-boot-tools.inc
3SUMMARY = "U-Boot bootloader tools"
4DEPENDS += "openssl"
5
6PROVIDES = "${MLPREFIX}u-boot-mkimage ${MLPREFIX}u-boot-mkenvimage"
7PROVIDES_class-native = "u-boot-mkimage-native u-boot-mkenvimage-native"
8
9PACKAGES += "${PN}-mkimage ${PN}-mkenvimage"
10
11# Required for backward compatibility with "u-boot-mkimage-xxx.bb"
12RPROVIDES_${PN}-mkimage = "u-boot-mkimage"
13RREPLACES_${PN}-mkimage = "u-boot-mkimage"
14RCONFLICTS_${PN}-mkimage = "u-boot-mkimage"
15
16EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
17EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
18EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
19
20SED_CONFIG_EFI = '-e "s/CONFIG_EFI_LOADER=.*/# CONFIG_EFI_LOADER is not set/"'
21SED_CONFIG_EFI_x86 = ''
22SED_CONFIG_EFI_x86-64 = ''
23SED_CONFIG_EFI_arm = ''
24SED_CONFIG_EFI_armeb = ''
25SED_CONFIG_EFI_aarch64 = ''
26
27do_compile () {
28 oe_runmake sandbox_defconfig
29
30 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
31 # generating it requires bin2header tool, which for target build
32 # is built with target tools and thus cannot be executed on host.
33 sed -i -e "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" ${SED_CONFIG_EFI} .config
34
35 oe_runmake cross_tools NO_SDL=1
36}
37
38do_install () {
39 install -d ${D}${bindir}
40
41 # mkimage
42 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
43 ln -sf uboot-mkimage ${D}${bindir}/mkimage
44
45 # mkenvimage
46 install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
47 ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
48
49 # dumpimage
50 install -m 0755 tools/dumpimage ${D}${bindir}/uboot-dumpimage
51 ln -sf uboot-dumpimage ${D}${bindir}/dumpimage
52
53 # fit_check_sign
54 install -m 0755 tools/fit_check_sign ${D}${bindir}/uboot-fit_check_sign
55 ln -sf uboot-fit_check_sign ${D}${bindir}/fit_check_sign
56}
57
58ALLOW_EMPTY_${PN} = "1"
59FILES_${PN} = ""
60FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage ${bindir}/uboot-dumpimage ${bindir}/dumpimage ${bindir}/uboot-fit_check_sign ${bindir}/fit_check_sign"
61FILES_${PN}-mkenvimage = "${bindir}/uboot-mkenvimage ${bindir}/mkenvimage"
62
63RDEPENDS_${PN}-mkimage += "dtc"
64RDEPENDS_${PN} += "${PN}-mkimage ${PN}-mkenvimage"
65RDEPENDS_${PN}_class-native = ""
66
67BBCLASSEXTEND = "native nativesdk"