summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2018-04-09 01:02:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:04 +0100
commit6cc503ed80850d6a3ec045da1a783ccda237e506 (patch)
tree179fbd32c883ffe2627c3b1a30ab1735bd9ae1fa /meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb
parentc5e230aba966bac565cdc18729c7e368059828e2 (diff)
downloadpoky-6cc503ed80850d6a3ec045da1a783ccda237e506.tar.gz
u-boot: Upgrade to 2018.03 release
This upgrades the U-Boot from 2018.01 to 2018.03 release and drops patches accepted upstream, getting the patch count to zero. (From OE-Core rev: c1d680326cabd10d0940827e8dfdc884f67b1e9a) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Ross Burton <ross.burton@intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb
new file mode 100644
index 0000000000..1c008be96e
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.03.bb
@@ -0,0 +1,29 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
7EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
8EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
9
10do_compile () {
11 oe_runmake sandbox_defconfig
12
13 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
14 # generating it requires bin2header tool, which for target build
15 # is built with target tools and thus cannot be executed on host.
16 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
17
18 oe_runmake cross_tools NO_SDL=1
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
24 ln -sf uboot-mkimage ${D}${bindir}/mkimage
25}
26
27RDEPENDS_${PN} += "dtc"
28
29BBCLASSEXTEND = "native nativesdk"