diff options
author | Marek Vasut <marex@denx.de> | 2018-01-19 18:45:02 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-01-22 10:39:09 +0000 |
commit | 289020cc23e30dbf0a81110b6679d2a1d4d0afd5 (patch) | |
tree | 68c1cfe6b1cdb0fe6744f0c9a618091c6aba0068 /meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb | |
parent | a54c639db0fe01b52b94a182448f879e9d5fea80 (diff) | |
download | poky-289020cc23e30dbf0a81110b6679d2a1d4d0afd5.tar.gz |
u-boot: Upgrade to 2018.01 release
This upgrades the U-Boot from 2017.11 to 2018.01 release
and drops patches accepted upstream.
(From OE-Core rev: df61422d3852b96d084749c0b287ea074f7e48bf)
Signed-off-by: Marek Vasut <marex@denx.de>
Cc: Otavio Salvador <otavio@ossystems.com.br>
Cc: Ross Burton <ross.burton@intel.com>
Cc: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb')
-rw-r--r-- | meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb new file mode 100644 index 0000000000..f1fc564492 --- /dev/null +++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2018.01.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | require u-boot-common_${PV}.inc | ||
2 | |||
3 | SUMMARY = "U-Boot bootloader image creation tool" | ||
4 | DEPENDS = "openssl" | ||
5 | |||
6 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' | ||
7 | EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' | ||
8 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' | ||
9 | |||
10 | do_compile () { | ||
11 | oe_runmake sandbox_defconfig | ||
12 | |||
13 | # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and | ||
14 | # generating it requires bin2header tool, which for target build | ||
15 | # is built with target tools and thus cannot be executed on host. | ||
16 | sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config | ||
17 | |||
18 | oe_runmake cross_tools NO_SDL=1 | ||
19 | } | ||
20 | |||
21 | do_install () { | ||
22 | install -d ${D}${bindir} | ||
23 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage | ||
24 | ln -sf uboot-mkimage ${D}${bindir}/mkimage | ||
25 | } | ||
26 | |||
27 | BBCLASSEXTEND = "native nativesdk" | ||