summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-11-14 16:32:23 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-30 10:49:21 +0000
commit3b97325b94129cca202137e5dc79cafceaf46e09 (patch)
tree8fa5cf46f81fdad6f8be088c3c5039942e71cc1c /meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb
parent42ac779aa35aa55e83bb6c52f633b00a80b481cd (diff)
downloadpoky-3b97325b94129cca202137e5dc79cafceaf46e09.tar.gz
u-boot: Upgrade to 2017.11 release
This upgrades the U-Boot from 2017.09 to 2017.11 release. (From OE-Core rev: 11413ee23f4eb3d52c1e9831f2c67f088370040a) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb
new file mode 100644
index 0000000000..f1fc564492
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.11.bb
@@ -0,0 +1,27 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl"
5
6EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
7EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
8EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
9
10do_compile () {
11 oe_runmake sandbox_defconfig
12
13 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
14 # generating it requires bin2header tool, which for target build
15 # is built with target tools and thus cannot be executed on host.
16 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
17
18 oe_runmake cross_tools NO_SDL=1
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
24 ln -sf uboot-mkimage ${D}${bindir}/mkimage
25}
26
27BBCLASSEXTEND = "native nativesdk"