summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 10:37:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 16:09:13 +0000
commit21db71990bdaac6740873f591fc11b2e54caa217 (patch)
tree3cf72fb657761c19fed11a899baa340252fd9b0c /meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
parent760e81678cec80dcdaab12c2a0a0148e3e0ba275 (diff)
downloadpoky-21db71990bdaac6740873f591fc11b2e54caa217.tar.gz
u-boot-mkimage: Fix use of 'cc' instead of BUILD_CC
OE needs to be able to change the default compiler. If we pass in HOSTCC through the make command, it overwrites not only this setting but also the setting in tools/Makefile wrapped in ifneq ($(CROSS_BUILD_TOOLS),) which breaks the build. We therefore add a way of changing the default in the top level Makefile without interfering with the other setting. I've emailed this workaround to Masahiro Yamada for discussion. (From OE-Core rev: e777d6873ce9a8a80288ecbcfc86239e0ed0e2f9) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
index c110226710..9b5772ec39 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
@@ -1,9 +1,11 @@
1require u-boot-common_${PV}.inc 1require u-boot-common_${PV}.inc
2 2
3SRC_URI += "file://default-gcc.patch"
4
3SUMMARY = "U-Boot bootloader image creation tool" 5SUMMARY = "U-Boot bootloader image creation tool"
4DEPENDS = "openssl" 6DEPENDS = "openssl"
5 7
6EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1' 8EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" DEFAULTHOSTCC="${BUILD_CC}" STRIP=true V=1'
7EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' 9EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
8EXTRA_OEMAKE_class-nativesdk = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' 10EXTRA_OEMAKE_class-nativesdk = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
9 11