summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-03-18 15:39:34 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 23:12:31 +0000
commit13a2a3f90d5cd75c528ffcd19d36686f952acfe6 (patch)
treed44e2b01d68ae1f2bb623399bba0ef1f39b2c3d4 /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
parentecf33963946bb3f1fd63d2d225cd6a92cd0a3678 (diff)
downloadpoky-13a2a3f90d5cd75c528ffcd19d36686f952acfe6.tar.gz
u-boot: Upgrade to 2016.03 release
The 2016.03 release has been announced in March 14th. This incorporates a lot of bug fixes and improvements which are useful for any new embedded development. Along with the upgrade of U-Boot and its related recipes, this patch also drops the AM335x environment fix which has been merged into the release. (From OE-Core rev: 15130f7bad0f0a1894c34bbb34a547722552c69e) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
new file mode 100644
index 0000000000..d5921a0443
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
@@ -0,0 +1,32 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
8# This revision corresponds to the tag "v2016.03"
9# We use the revision in order to avoid having to fetch it from the
10# repo during parse
11SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
12
13PV = "v2016.03+git${SRCPV}"
14
15SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
20
21do_compile () {
22 oe_runmake sandbox_defconfig
23 oe_runmake cross_tools NO_SDL=1
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
29 ln -sf uboot-mkimage ${D}${bindir}/mkimage
30}
31
32BBCLASSEXTEND = "native nativesdk"