summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-02-10 13:56:00 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-14 08:40:59 +0000
commit34a4413ef7a873e8bfed4153173cc7050965510b (patch)
treeea24d7359fe1c57f4ddda08b8a0db6e97d19655a /meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
parent1993237a90fb12de37d9212f900e48ebe67e9f55 (diff)
downloadpoky-34a4413ef7a873e8bfed4153173cc7050965510b.tar.gz
u-boot: update to version 2015.01
(From OE-Core rev: 62052810dbf3ed19697078a48b617bfbdadf2a29) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
deleted file mode 100644
index eabf680ec6..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2014.07.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
4SECTION = "bootloader"
5
6# This revision corresponds to the tag "v2014.07"
7# We use the revision in order to avoid having to fetch it from the
8# repo during parse
9SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
10
11PV = "v2014.07+git${SRCPV}"
12
13SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
18
19do_compile () {
20 # Make sure the recompile is OK
21 rm -f ${B}/tools/.depend
22
23 make HOSTCC="${BUILD_CC}" HOSTLD="${BUILD_LD}" HOSTLDFLAGS="${BUILD_LDFLAGS}" HOSTSTRIP=true dot-config=0 scripts_basic
24 sed 's/^tools-only: scripts_basic /tools-only: /' -i Makefile
25 oe_runmake tools-only
26}
27
28do_install () {
29 install -d ${D}${bindir}
30 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
31 ln -sf uboot-mkimage ${D}${bindir}/mkimage
32}
33
34BBCLASSEXTEND = "native nativesdk"