diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-04-22 15:11:08 -0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-04-26 10:05:13 +0100 |
commit | 8545bea9a01faad480c6700ee388f3d70b3bcb4f (patch) | |
tree | 598565dd8f4ca2cf63a990012cd57cdda9618417 /meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb | |
parent | 79591eb7d257050dce8f30e1b586984cfeb0b5b3 (diff) | |
download | poky-8545bea9a01faad480c6700ee388f3d70b3bcb4f.tar.gz |
u-boot-mkimage: add 2012.04 release
(From OE-Core rev: e1b1b6313b57d069ef77bc6e1e1ebbb8f6fdda4e)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb')
-rw-r--r-- | meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb new file mode 100644 index 0000000000..9d59ef3a65 --- /dev/null +++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "U-boot bootloader mkimage tool" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" | ||
4 | SECTION = "bootloader" | ||
5 | |||
6 | # This is needs to be validated among supported BSP's before we can | ||
7 | # make it default | ||
8 | DEFAULT_PREFERENCE = "-1" | ||
9 | |||
10 | # This revision corresponds to the tag "v2012.04" | ||
11 | # We use the revision in order to avoid having to fetch it from the | ||
12 | # repo during parse | ||
13 | SRCREV = "2790bf69dc12fb9aeb9836904e5f57c7f83d5552" | ||
14 | |||
15 | PV = "v2012.04+git${SRCPV}" | ||
16 | |||
17 | SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true' | ||
22 | |||
23 | do_compile () { | ||
24 | oe_runmake tools | ||
25 | } | ||
26 | |||
27 | do_install () { | ||
28 | install -d ${D}${bindir} | ||
29 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage | ||
30 | ln -sf uboot-mkimage ${D}${bindir}/mkimage | ||
31 | } | ||
32 | |||
33 | BBCLASSEXTEND = "native nativesdk" | ||