summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-25 16:28:08 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 10:05:18 +0100
commit1b6cba69692335ef5dcaa2d5d2ef388d08fd6ae2 (patch)
tree46a2249bb8b1d4dd29be56b337be9434510bf06a /meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb
parent967bd67c374cc3a80620843f059507a06c93a550 (diff)
downloadpoky-1b6cba69692335ef5dcaa2d5d2ef388d08fd6ae2.tar.gz
u-boot-mkimage: update 2012.04 to 2012.04.01 release
(From OE-Core rev: bf8819a1aafeeaa3ce4c8eeda09f882bd9e18600) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb
new file mode 100644
index 0000000000..aa107fe431
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2012.04.01.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "U-boot bootloader mkimage tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5
6# This is needs to be validated among supported BSP's before we can
7# make it default
8DEFAULT_PREFERENCE = "-1"
9
10# This revision corresponds to the tag "v2012.04.01"
11# We use the revision in order to avoid having to fetch it from the
12# repo during parse
13SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d"
14
15PV = "v2012.04.01+git${SRCPV}"
16
17SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
22
23do_compile () {
24 oe_runmake tools
25}
26
27do_install () {
28 install -d ${D}${bindir}
29 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
30 ln -sf uboot-mkimage ${D}${bindir}/mkimage
31}
32
33BBCLASSEXTEND = "native nativesdk"