summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2018-05-16 22:14:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:07:12 +0100
commitb3588b0ca9889d83e09ecc50eefd3727011d5f79 (patch)
tree96a1cd261936d8a4cb9cfbbc3d2a3d3590f6248a /meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
parent074b2e8c2f8cef4e75e0c36811655d71aad50c53 (diff)
downloadpoky-b3588b0ca9889d83e09ecc50eefd3727011d5f79.tar.gz
u-boot: Upgrade to 2018.05 release
This upgrades the U-Boot from 2018.03 to 2018.05 release. (From OE-Core rev: 8e8cea4569ffa8ea81b7e99f98f9dab203614d22) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Ross Burton <ross.burton@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
new file mode 100644
index 0000000000..02887a138a
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2018.05.bb
@@ -0,0 +1,34 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils"
5
6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
8EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
9
10inherit uboot-config
11
12do_compile () {
13 oe_runmake ${UBOOT_MACHINE}
14 oe_runmake envtools
15}
16
17do_install () {
18 install -d ${D}${base_sbindir}
19 install -d ${D}${sysconfdir}
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
21 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
22 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
23}
24
25do_install_class-cross () {
26 install -d ${D}${bindir_cross}
27 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
28 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
29}
30
31SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
32
33PACKAGE_ARCH = "${MACHINE_ARCH}"
34BBCLASSEXTEND = "cross"