summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-09-11 17:30:56 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-13 22:07:42 +0100
commit03634c1d0ceb4cd0c90097b43ca5d17a74e1f0cc (patch)
tree08b57457c40f2705539064bbc3e5772aa7c81b4a /meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
parent7401de0beb2de614566b701f0fddae7e825b3e0f (diff)
downloadpoky-03634c1d0ceb4cd0c90097b43ca5d17a74e1f0cc.tar.gz
u-boot: Upgrade to 2017.09
This upgrades the U-Boot to the 2017.09 release. (From OE-Core rev: 340d413f678a4a64dfa060e8fe0ac721b73fed97) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
new file mode 100644
index 0000000000..c2e8f0fb84
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.09.bb
@@ -0,0 +1,34 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils"
5
6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
8EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
9
10inherit uboot-config
11
12do_compile () {
13 oe_runmake ${UBOOT_MACHINE}
14 oe_runmake env
15}
16
17do_install () {
18 install -d ${D}${base_sbindir}
19 install -d ${D}${sysconfdir}
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
21 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
22 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
23}
24
25do_install_class-cross () {
26 install -d ${D}${bindir_cross}
27 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
28 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
29}
30
31SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
32
33PACKAGE_ARCH = "${MACHINE_ARCH}"
34BBCLASSEXTEND = "cross"