summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-11-18 11:18:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-08 10:31:30 +0000
commit595f36bea841321e4e670ed22765aa37e7bf2c66 (patch)
tree9daafb0adc701d004c69d4b604df1353881f2630 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
parenta4d976cb20770346ee2c8e9ac63ace5295afbc97 (diff)
downloadpoky-595f36bea841321e4e670ed22765aa37e7bf2c66.tar.gz
u-boot: Update to v2016.11 release
Upgrade U-Boot to the latest version. (From OE-Core rev: 34f1d3824fd45cd0bb28b3cbc33907cfd885f841) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Denys Dmytriyenko <denis@denix.org> Cc: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
new file mode 100644
index 0000000000..f56862cb27
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
@@ -0,0 +1,34 @@
1require u-boot-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils"
5
6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
8EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
9
10inherit uboot-config
11
12do_compile () {
13 oe_runmake ${UBOOT_MACHINE}
14 oe_runmake env
15}
16
17do_install () {
18 install -d ${D}${base_sbindir}
19 install -d ${D}${sysconfdir}
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
21 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
22 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
23}
24
25do_install_class-cross () {
26 install -d ${D}${bindir_cross}
27 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
28 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
29}
30
31SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
32
33PACKAGE_ARCH = "${MACHINE_ARCH}"
34BBCLASSEXTEND = "cross"